project-navigation
Personal tools

Author Topic: A call for testing help  (Read 2872 times)

Offline Duke

  • Administrator
  • PHALANX veteran
  • *****
  • Posts: 1037
    • View Profile
A call for testing help
« on: October 19, 2008, 12:45:40 am »
Could anyone who runs ufo 2.3 on Window$ please do a quick test for me :

Check if you can switch to a language different from your machine's default setting.
Hint: chose a language that you can understand a bit, or switching back might be a challenge ;)

That worked fine in 2.2.1, but doesn't work for me in 2.3.

If the test fails, plz report here.
If you should succeed, plz report the type of Window$ you use (W2k, XP, Vista ?)

t.i.a.

Offline Kildor

  • Project Artist
  • Captain
  • ***
  • Posts: 757
  • Project mapper and some other stuff`er
    • View Profile
    • http://ufoai.nx0.ru
Re: A call for testing help
« Reply #1 on: October 19, 2008, 04:58:27 am »
no, it failed for me (I write about in other forum`s theme).
Last trunk, WinXP32 SP2

Offline Mattn

  • CaveExpress
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4830
  • www.caveproductions.org
    • View Profile
    • CaveExpress
Re: A call for testing help
« Reply #2 on: October 19, 2008, 10:07:50 am »
maybe also SDL_putenv related?

Offline Duke

  • Administrator
  • PHALANX veteran
  • *****
  • Posts: 1037
    • View Profile
Re: A call for testing help
« Reply #3 on: October 19, 2008, 09:12:55 pm »
@Mattn:
I think so.

@Kildor:
Thanks. At least we now know that we're not alone...

However, 1 or 2 more Windows user who can confirm would be great...

Offline RudolfoWood

  • Rookie
  • ***
  • Posts: 85
    • View Profile
Re: A call for testing help
« Reply #4 on: October 22, 2008, 05:43:21 pm »
I can confirm, it worked in 2.3, but for some time now, it does not do anything (and so is broken)... can't give the revision that broke it.

Offline Duke

  • Administrator
  • PHALANX veteran
  • *****
  • Posts: 1037
    • View Profile
Re: A call for testing help
« Reply #5 on: October 22, 2008, 10:55:26 pm »
@Kildor & Rudolfo:
You may also want to try the fix I suggested in the 'MSVC ?'-thread in the 'Coding'-forum and tell me if it solves the prob for you, too ?
 

Offline RudolfoWood

  • Rookie
  • ***
  • Posts: 85
    • View Profile
Re: A call for testing help
« Reply #6 on: October 23, 2008, 05:52:51 pm »
this would solve the problems that language could not be changed (not the problems in bug report as this would take some work :-) )

Offline Duke

  • Administrator
  • PHALANX veteran
  • *****
  • Posts: 1037
    • View Profile
Re: A call for testing help
« Reply #7 on: October 23, 2008, 10:15:07 pm »
Yup. The putenv change is just for switching between languages.
Have you tried it ?

Offline RudolfoWood

  • Rookie
  • ***
  • Posts: 85
    • View Profile
Re: A call for testing help
« Reply #8 on: October 25, 2008, 11:24:34 am »
yes, tried it and it did work (if this was not clear in my last post)