project-navigation
Personal tools

Author Topic: Antartida  (Read 4026 times)

kabrquero

  • Guest
Antartida
« on: September 28, 2008, 07:31:13 pm »
When i try to land in antartida, i have a problems, the game finish. When i load the game with the terminal i have this traces.

...subsystem 'transfer' - saved 86400 bytes
Campaign 'QuickSave' saved.
Floating point exception


i try to reinstall but the problem persist.

thank and sorry for my bad english

Offline Mattn

  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4831
  • https://github.com/mgerhardy/vengi
    • View Profile
    • Vengi Voxel Tools
Re: Antartida
« Reply #1 on: September 28, 2008, 07:48:30 pm »
please attach your savegame - otherwise we can't help you

malachai

  • Guest
Re: Antartida
« Reply #2 on: October 15, 2008, 12:32:10 pm »
I have the same problem. The game crashes everytime I want to enter the site of shot-down UFO (hopefully auto-mission works) and when trying to enter Antartida.
I run Ubuntu 8.04 and latest stable version of UFO:AI

ADD: I can't enter area with shot down UFO anywhere on the planet, not just Antarctica
« Last Edit: October 15, 2008, 03:18:43 pm by malachai »

Offline Destructavator

  • Combination Multiple Specialty Developer
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 1908
  • Creater of Scorchcrafter, knows the zarakites...
    • View Profile
Re: Antartida
« Reply #3 on: October 15, 2008, 01:40:00 pm »
I think I recall having this problem as well with the last official release occasionally (but not always), although I haven't played 2.2.1 in quite some time, and I don't know if this bug is still in the game (in the development trunk) or not.

I'll see if I can reproduce this bug in the latest SVN snapshot, perhaps by installing radars and SAM sites in Antarctica, or otherwise trying to shoot down a UFO in that area, and then post here again if I see this bug come up (and include logs and a savegame attachment).

Satanic Mechanic

  • Guest
Re: Antartida
« Reply #4 on: October 27, 2008, 11:46:24 pm »
I had this same problem running 2.2.1 on hardy, after some searching of the forums, it appears it is related to the music package, more specifically the lack there off.

Being as I always turn game music off, when I first downloaded 2.2.1, I decided against downloading the music package in synaptic, however, whenever the game got to a mission involving a crashed or landed ufo (ie antarctica, shot down ufo's) any attempt to enter the mission resulted in a game crash, although auto resolve, when available, worked.

I've since downloaded the music package and have not encountered the problem again. Hope this helps.