project-navigation
Personal tools

Author Topic: 2.3 - Crash Upon Starting Campaign  (Read 2629 times)

Offline Sangel

  • Cannon Fodder
  • **
  • Posts: 3
    • View Profile
2.3 - Crash Upon Starting Campaign
« on: July 03, 2010, 09:36:18 pm »
System Specifications:
2007 Macbook Pro (2 GHz Core Duo, 2GB RAM)
Mac OS 10.6.4

Problem:
Glitchy graphics, followed by a crash, after the campaign introduction, but before the Geoscape appears.

Attempted Resolution #1:
Set the display resolution to the native 1440x900, and switched to full-screen. No luck - the crash reoccurs.

Attempted Resolution #2:
The same as attempt #1, but additionally disabling GLSL shaders. Mixed results; the game now sometimes crashes on launch, but at other times I can start a new campaign and get to the Geoscape.

Offline geever

  • Project Coder
  • PHALANX Commander
  • ***
  • Posts: 2557
    • View Profile
Re: 2.3 - Crash Upon Starting Campaign
« Reply #1 on: July 03, 2010, 09:53:43 pm »
System Specifications:
2007 Macbook Pro (2 GHz Core Duo, 2GB RAM)
Mac OS 10.6.4

Problem:
Glitchy graphics, followed by a crash, after the campaign introduction, but before the Geoscape appears.

Attempted Resolution #1:
Set the display resolution to the native 1440x900, and switched to full-screen. No luck - the crash reoccurs.

Attempted Resolution #2:
The same as attempt #1, but additionally disabling GLSL shaders. Mixed results; the game now sometimes crashes on launch, but at other times I can start a new campaign and get to the Geoscape.

define crash! ufoconsole log? stacktrace?
or give me a 2007 MacBook Pro to reproduce :P

-geever

Offline Sangel

  • Cannon Fodder
  • **
  • Posts: 3
    • View Profile
Re: 2.3 - Crash Upon Starting Campaign
« Reply #2 on: July 03, 2010, 10:26:40 pm »
Unfortunately, the UFO console-log appears to be overwritten with each new launch... and I can't seem to reproduce the bug by turning GLSL shaders back on. Very bizarre. I will be sure to capture the log on future crashes.

While the game is no longer crashing, I am experiencing two further issues:

#1 - No Sound
I currently have no sound or music. Perhaps because of this line "2010/07/03 15:17:03 ... could not load ogg vorbis support"
I am attaching my log to this post. Any suggestions on fixes are welcome - is there a library that I need to download and install?

#2 - 3D Geoscape does not display properly
The entire earth appears to be in night mode simultaneously, rather than one half being lit by the sun. I am attaching a screenshot where the sun's position should produce both day and night effects.




I am attaching the log from my latest run:

Offline Mattn

  • CaveExpress
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4830
  • www.caveproductions.org
    • View Profile
    • CaveExpress
Re: 2.3 - Crash Upon Starting Campaign
« Reply #3 on: July 03, 2010, 10:55:53 pm »
try to increase the geoscape ambient lighting in the options menu

Offline Sangel

  • Cannon Fodder
  • **
  • Posts: 3
    • View Profile
Re: 2.3 - Crash Upon Starting Campaign
« Reply #4 on: July 03, 2010, 11:01:59 pm »
try to increase the geoscape ambient lighting in the options menu
Increasing the ambient lighting setting to maximum increases the intensity of the lights, but does not appear to resolve the night/day issue. See attached screenshot.

Fortunately, the game is still playable using the 2D geoscape - though I think it might be worth tweaking the UI while in 2D mode so that you can scroll with a more intuitive left/right arrow setup, rather than the 3D-focused globe-spinning interface.