Personal tools

Author Topic: error: 'game_import_t' has no member named '__dprintf_chk'  (Read 5059 times)


  • Guest
error: 'game_import_t' has no member named '__dprintf_chk'
« on: August 19, 2008, 05:52:01 pm »

I'm trying to compile UFO:AI on Gentoo Linux amd64. I have tried both the SVN version, and the ebuild in Portage. Both exit with the following errors:

Code: [Select]
* [GAM] src/game/g_client.c
src/game/g_client.c: In function 'G_InventoryToFloor':
src/game/g_client.c:956: error: 'game_import_t' has no member named '__dprintf_chk'
src/game/g_client.c:958: error: 'game_import_t' has no member named '__dprintf_chk'
src/game/g_client.c: In function 'G_ActorDie':
src/game/g_client.c:1702: error: 'game_import_t' has no member named '__dprintf_chk'
src/game/g_client.c: In function 'G_GetTeam':
src/game/g_client.c:1837: error: 'game_import_t' has no member named '__dprintf_chk'
src/game/g_client.c:1850: error: 'game_import_t' has no member named '__dprintf_chk'
src/game/g_client.c:1850: error: expected expression before ')' token
src/game/g_client.c:1857: error: 'game_import_t' has no member named '__dprintf_chk'
src/game/g_client.c:1869: error: 'game_import_t' has no member named '__dprintf_chk'
src/game/g_client.c:1876: error: 'game_import_t' has no member named '__dprintf_chk'
src/game/g_client.c:1882: error: 'game_import_t' has no member named '__dprintf_chk'
src/game/g_client.c: In function 'G_ClientTeamInfo':
src/game/g_client.c:2025: error: 'game_import_t' has no member named '__dprintf_chk'
make: *** [release-linux-gnu-x86_64/game/game/g_client.o] Error 1

Does anybody have any insight on this?



  • Guest
Re: error: 'game_import_t' has no member named '__dprintf_chk'
« Reply #1 on: August 20, 2008, 08:44:06 am »
I switched from gcc 4.12 to 4.31, and now make completes successfully. However, there are still problems. The game loads into the main menu just fine, and plays the menu music, but it is not responsive to mouse clicks. The crosshair cursor looks good and mouse motion is fine. I have to exit the program through the window manager's close button. Maybe I need to recompile some mouse package with the new gcc? Attached is the console log.

Code: [Select]
cheesinglee@SirPoppinFresh ~/svn/trunk $ ./ufo

---- filesystem initialization -----
Adding game dir: /usr/local/lib/ufoai/base
Adding game dir: /usr/local/share/ufoai/base
Adding game dir: ./base
Added packfile ./base/0base.pk3 (5 files)
Added packfile ./base/0maps.pk3 (353 files)
Added packfile ./base/0materials.pk3 (9 files)
Added packfile ./base/0media.pk3 (11 files)
Added packfile ./base/0models.pk3 (1373 files)
Added packfile ./base/0music.pk3 (40 files)
Added packfile ./base/0pics.pk3 (1986 files)
Added packfile ./base/0snd.pk3 (169 files)
Added packfile ./base/0ufos.pk3 (78 files)
using /home/cheesinglee/.ufoai/2.3-dev/base for writing
Adding game dir: /home/cheesinglee/.ufoai/2.3-dev/base
execing default.cfg
execing config.cfg
execing keys.cfg

----- network initialization -------
libcurl/7.18.2 OpenSSL/0.9.8h zlib/1.2.3 initialized.

------ server initialization -------
added 7 maps to the mapcycle
...using language: C

----- console initialization -------
loaded console history commands: 1
Console initialized.

------- video initialization -------
SDL version: 1.2.13
I: desktop depth: 32bpp
I: video memory: 0
I: video driver: x11
I: setting mode 6: 1024x768 (fullscreen: no)
I: set swap control to 0
I: got 8 bits of stencil
I: got 24 bits of depth buffer
I: got double buffer
I: got 8 bits for red
I: got 8 bits for green
I: got 8 bits for blue
I: got 0 bits for alpha
I: got 0 multisample buffers
GL_VERSION: 2.1.2 NVIDIA 173.14.12
GL_EXTENSIONS: GL_ARB_color_buffer_float GL_ARB_depth_texture GL_ARB_draw_buffers GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_half_float_pixel GL_ARB_imaging GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_shadow GL_ARB_shader_objects GL_ARB_shading_language_100 GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_dot3 GL_ARB_texture_float GL_ARB_texture_mirrored_repeat GL_ARB_texture_non_power_of_two GL_ARB_texture_rectangle GL_ARB_transpose_matrix GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos GL_ATI_draw_buffers GL_ATI_texture_float GL_ATI_texture_mirror_once GL_S3_s3tc GL_EXT_texture_env_add GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_compiled_vertex_array GL_EXT_Cg_shader GL_EXT_bindable_uniform GL_EXT_depth_bounds_test GL_EXT_draw_buffers2 GL_EXT_draw_instanced GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_framebuffer_object GL_EXTX_framebuffer_mixed_formats GL_EXT_framebuffer_sRGB GL_EXT_geometry_shader4 GL_EXT_gpu_program_parameters GL_EXT_gpu_shader4 GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_float GL_EXT_packed_pixels GL_EXT_pixel_buffer_object GL_EXT_point_parameters GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_texture3D GL_EXT_texture_array GL_EXT_texture_buffer_object GL_EXT_texture_compression_latc GL_EXT_texture_compression_rgtc GL_EXT_texture_compression_s3tc GL_EXT_texture_cube_map GL_EXT_texture_edge_clamp GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic GL_EXT_texture_integer GL_EXT_texture_lod GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_object GL_EXT_texture_sRGB GL_EXT_texture_shared_exponent GL_EXT_timer_query GL_EXT_vertex_array GL_IBM_rasterpos_clip GL_IBM_texture_mirrored_repeat GL_KTX_buffer_region GL_NV_blend_square GL_NV_copy_depth_to_color GL_NV_depth_buffer_float GL_NV_conditional_render GL_NV_depth_clamp GL_NV_fence GL_NV_float_buffer GL_NV_fog_distance GL_NV_fragment_program GL_NV_fragment_program_option GL_NV_fragment_program2 GL_NV_framebuffer_multisample_coverage GL_NV_geometry_shader4 GL_NV_gpu_program4 GL_NV_half_float GL_NV_light_max_exponent GL_NV_multisample_coverage GL_NV_multisample_filter_hint GL_NV_occlusion_query GL_NV_packed_depth_stencil GL_NV_parameter_buffer_object GL_NV_pixel_data_range GL_NV_point_sprite GL_NV_primitive_restart GL_NV_register_combiners GL_NV_register_combiners2 GL_NV_texgen_reflection GL_NV_texture_compression_vtc GL_NV_texture_env_combine4 GL_NV_texture_expand_normal GL_NV_texture_rectangle GL_NV_texture_shader GL_NV_texture_shader2 GL_NV_texture_shader3 GL_NV_transform_feedback GL_NV_vertex_array_range GL_NV_vertex_array_range2 GL_NV_vertex_program GL_NV_vertex_program1_1 GL_NV_vertex_program2 GL_NV_vertex_program2_option GL_NV_vertex_program3 GL_NVX_conditional_render GL_SGIS_generate_mipmap GL_SGIS_texture_lod GL_SGIX_depth_texture GL_SGIX_shadow GL_SUN_slice_accum
ignoring GL_ARB_texture_compression
using GL_EXT_texture_filter_anisotropic [16 max] [ 1 selected]
using GL_EXT_texture_lod_bias
using GL_ARB_fragment_program
using GL_ARB_shading_language_100
ignoring GL_ARB_vertex_buffer_object
max texture units: 4
max texture size: detected 8192
but using 2048 as requested
SDL_ttf version 2.0.9 - we need at least 2.0.7

------- sound initialization -------
SDL_mixer version: 1.2.8
... audio rate: 44100
... audio channels: 2
... driver: 'alsa'

------- input initialization -------
0 possible joysticks
no joystick found.

--- save subsystem initialization --
added size subsystem (check ff)
added base subsystem (check 0)
added campaign subsystem (check 1)
added hospital subsystem (check 2)
added market subsystem (check 3)
added research subsystem (check 4)
added employee subsystem (check 5)
added aliencont subsystem (check 6)
added production subsystem (check 7)
added aircraft subsystem (check 8)
added messagesystem subsystem (check 9)
added stats subsystem (check a)
added nations subsystem (check b)
added transfer subsystem (check c)
added alien base subsystem (check d)
added xvirate subsystem (check e)
added installation subsystem (check 0)

----------- parse scripts ----------
Shared Client/Server Info loaded
...107 items parsed
... 32 damage types parsed
... 63 map definitions parsed
... 26 equipment definitions parsed
... 10 inventory definitions parsed
... 22 team definitions parsed
music change to van_theme (from PsymongN3)
execing autoexec.cfg
"version" is "UFO: Alien Invasion 2.3-dev x86_64 Aug 19 2008 Linux RELEASE"
S_Music_Start: Playing music: 'music/van_theme'
R_RegisterModelShort: Could not find: 'weapons/autocannon/autocannon'
CL_LanguageInit: language settings are stored in configuration: C
Could not find locale with id 'C'
124 static models loaded
...uploaded 5 shaders
====== UFO Initialized ======

Switch grab input off
Wrote config.cfg.
Wrote keys.cfg
recursive shutdown

Offline Mattn

  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4831
    • View Profile
    • Vengi Voxel Tools
Re: error: 'game_import_t' has no member named '__dprintf_chk'
« Reply #2 on: August 20, 2008, 11:12:33 am »
are you running fullscreen or windowed? try to run it fullscreen - or hit ctrl+g while you are running it in windowed mode (mouse grab)


  • Guest
Re: error: 'game_import_t' has no member named '__dprintf_chk'
« Reply #3 on: August 20, 2008, 05:20:02 pm »
Nope, still no mouse clicks with either solution. In fullscreen mode, I was unable to alt+tab, but I was able to to use tab to cycle through the menu buttons and enter to select them.

Offline Wizard^^

  • Rookie
  • ***
  • Posts: 22
    • View Profile
Re: error: 'game_import_t' has no member named '__dprintf_chk'
« Reply #4 on: November 23, 2008, 11:50:03 am »
I´m have the same type of problem. It all looks and sounds fine but UFOAI just wont listen to mouse button clicks.

I just compiled it from the trunk svn and I´m running fedora 9 x86_64.
« Last Edit: November 23, 2008, 03:09:25 pm by Wizard^^ »

Offline geever

  • Project Coder
  • PHALANX Commander
  • ***
  • Posts: 2561
    • View Profile
Re: error: 'game_import_t' has no member named '__dprintf_chk'
« Reply #5 on: November 23, 2008, 12:18:56 pm »
Try removing ~/.ufoai/<version>/base/keys.cfg


Offline Wizard^^

  • Rookie
  • ***
  • Posts: 22
    • View Profile
Re: error: 'game_import_t' has no member named '__dprintf_chk'
« Reply #6 on: November 23, 2008, 03:17:03 pm »
Cool that worked.   ;D

The file had only this.
Code: [Select]
// generated by ufo, do not modify
// If you want to know the keyname of a specific key - set in_debug cvar to 1 and press the key
looks like it needs bindmenu JOY1 "+leftmouse"

Well now it works. Thanks

Offline geever

  • Project Coder
  • PHALANX Commander
  • ***
  • Posts: 2561
    • View Profile
Re: error: 'game_import_t' has no member named '__dprintf_chk'
« Reply #7 on: November 23, 2008, 07:48:13 pm »
Mattn, it's a common problem do you have any idea why does it happen? (Corrupt keys.cfg created on first run.)