project-navigation
Personal tools

Author Topic: Win32 Development Binary Installer Links  (Read 339880 times)

Offline gerald

  • Rookie
  • ***
  • Posts: 79
    • View Profile
Re: Win32 Development Binary Installer Links
« Reply #285 on: August 13, 2009, 04:29:42 pm »
hmm i downloaded version posted up there now when i start game console is loading then startgame screen blink and all gone lol i uninstalled 2.2.1 also i saw so its no wrote any config.cfg in application data as 2.2.1 did its only "ufoconsole" file there...:/

Offline gerald

  • Rookie
  • ***
  • Posts: 79
    • View Profile
Re: Win32 Development Binary Installer Links
« Reply #286 on: August 13, 2009, 10:16:36 pm »
its working after i added line u gaved me in console many thx :)

Offline Destructavator

  • Combination Multiple Specialty Developer
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 1908
  • Creater of Scorchcrafter, knows the zarakites...
    • View Profile
Win32 Dev Installer Link (r26052)
« Reply #287 on: September 06, 2009, 06:14:07 am »
I'm currently uploading a new Windows installer, revision 26052.

This is right from my working copy, it has not been tested (at all) and may have a few additional files I was using to test things with, although the official files are consistent with the SVN.  In addition, radiant did not compile properly, but the game itself should run.

I apologize for it not being nice and neat, but I haven't done this in a while and I'm mainly doing it right now (overnight while I sleep, actually) because forum member Odie is dealing with other things right now that are occupying his time, and he was uploading installers on a regular basis for quite a while.

ETA is ~8 hours from this post, I'll provide a direct link URL when it is done.

Edit:  This is interesting - the NSIS installer packaging script apparently included the r25712.chm and HTML documentation for the API in the installer, and it unpacked it when I just tested the installer.  It's too bad it didn't also pack the new codeblocks.zip, that was in the "contrib" folder which didn't get packed.

« Last Edit: September 06, 2009, 06:22:03 am by Destructavator »

Offline Destructavator

  • Combination Multiple Specialty Developer
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 1908
  • Creater of Scorchcrafter, knows the zarakites...
    • View Profile
Re: Win32 Development Binary Installer Links
« Reply #288 on: September 06, 2009, 03:59:45 pm »

Offline Destructavator

  • Combination Multiple Specialty Developer
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 1908
  • Creater of Scorchcrafter, knows the zarakites...
    • View Profile
Re: Win32 Development Binary Installer Links
« Reply #289 on: September 07, 2009, 05:10:04 am »
OK, I managed to recompile a revision 26082 with a working copy of radiant, and package it more properly this time.   :)

I'll try to upload it tonight.  I'm now uploading, I'll post link when it is done.

Edit: About one more hour to go...
« Last Edit: September 07, 2009, 12:09:49 pm by Destructavator »

Offline Destructavator

  • Combination Multiple Specialty Developer
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 1908
  • Creater of Scorchcrafter, knows the zarakites...
    • View Profile
Re: Win32 Development Binary Installer Links
« Reply #290 on: September 07, 2009, 01:01:39 pm »

Offline MXcom

  • Rookie
  • ***
  • Posts: 45
    • View Profile
Re: Win32 Development Binary Installer Links
« Reply #291 on: September 08, 2009, 02:13:26 pm »
OK, here it is:

http://destructavator.com/92dl/ufoai2_3dev_r26082.exe


Thanks for uploading, but the sound is choppy. Could it be an error of your build, or is it a bug? (or, did I do something wrong?)

Offline Destructavator

  • Combination Multiple Specialty Developer
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 1908
  • Creater of Scorchcrafter, knows the zarakites...
    • View Profile
Re: Win32 Development Binary Installer Links
« Reply #292 on: September 08, 2009, 02:35:31 pm »
Thanks for uploading, but the sound is choppy. Could it be an error of your build, or is it a bug? (or, did I do something wrong?)

I'll run the installer on one of my test machines and see if I can reproduce the problem.  In the meantime:

- In what part of the game is the sound choppy?  The whole thing, all the time, during all missions?  Or just one area?

- Can you please tell what version of Windows you are running and a few basic hardware specs about the machine you're running it on?

Offline MXcom

  • Rookie
  • ***
  • Posts: 45
    • View Profile
Re: Win32 Development Binary Installer Links
« Reply #293 on: September 08, 2009, 07:42:36 pm »
The whole thing, all the time. As soon as some music starts playing (when loading the game), it's messed up. I've tried different settings in the sound menu, and on the lowest available sample rate, I can at least hear the music (but in horrible quality). On any other rate, all I hear is mess.
Maybe there the problem lies somewhere. I read some changelogs concerning OpenAL lately (?), maybe there was a bug introduced there.
Btw, the last build I tested (r25862 built by odie) ran fine for me, without any sound problems.

I'm running
Windows XP
Home Edition
Version 2002
Service Pack 2

on an ASUS A6JM laptop with
Intel Core2 Duo T5500 @ 1.66GHz
1.65GHz, 1GB RAM


edit: hmm, maybe the fault lies somewhere in my settings. Strangely, the problems now also exist when I run one of the older builds that ran fine previously... :(

edit2: hmm, here's something from the console that might be of interest: firstly what driver and versions are running, and then, everytime I change the rate and click on "restart sound", it seems to miss a sound file 'nife'... :/
Code: [Select]
------- sound initialization -------
SDL_mixer version: 1.2.8
... driver: 'dsound'
... audio rate: 11025
... audio channels: 2
S_LoadSound: Could not find sound file: 'nife'

edit3: now it even kicked me out (no further info in ufoconsole.log, no crash files...), when I clicked on "restart sound" without changing the sample rate beforehand during running game...
« Last Edit: September 08, 2009, 08:05:35 pm by MXcom »

Ain Soph Aur

  • Guest
Re: Win32 Development Binary Installer Links
« Reply #294 on: September 09, 2009, 01:41:02 am »
I just packaged 18915, which appears to work on my system (very quick test), I'll try to upload it overnight and replace this text with a link when it's up.

BTW, the maps compiled (from scratch) on this brand new machine I just got went by quickly, all of them done in just half an hour!  :o

EDIT:  Here it is:

http://www.destructavator.com/public/UFOAI_2-3-Dev_r18915.zip

I'm still having headaches with compiling GTKRadiant and getting it to package properly, but the actual game should work.
This package was created under Vista Home Premium, 32-bit.

i can not download the .zip

error is:

Not Found
The requested URL http:// was not found on this server.

Offline Destructavator

  • Combination Multiple Specialty Developer
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 1908
  • Creater of Scorchcrafter, knows the zarakites...
    • View Profile
Re: Win32 Development Binary Installer Links
« Reply #295 on: September 09, 2009, 02:46:52 am »
i can not download the .zip

error is:

Not Found
The requested URL http:// was not found on this server.

That's because you tried to download a very old revision, from a directory I cleaned out a long time ago.  The latest I've uploaded is 26082.  You tried to grab 18915, which I think is over a year old.  (Hint: As I upload new revisions I place them in new posts, so the most recent are near the *end* of this forum thread, the one in the very first post is the *oldest*.)

Why would you want such an old and outdated buggy test build anyways?

@MXcom:  I'm afraid one of the coders will have to help you here, you may want to post in the "2.3 bugs" section of the forum where they will see it.  I don't know if this bug you're experiencing is already fixed in the SVN or not.
« Last Edit: September 09, 2009, 02:49:27 am by Destructavator »

Offline Destructavator

  • Combination Multiple Specialty Developer
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 1908
  • Creater of Scorchcrafter, knows the zarakites...
    • View Profile
Re: Win32 Development Binary Installer Links
« Reply #296 on: September 12, 2009, 02:19:15 am »
Now uploading r26164, will post a link when it is ready.

Offline Destructavator

  • Combination Multiple Specialty Developer
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 1908
  • Creater of Scorchcrafter, knows the zarakites...
    • View Profile

Offline Tlactar

  • Rookie
  • ***
  • Posts: 60
    • View Profile
Re: Win32 Development Binary Installer Links
« Reply #298 on: September 12, 2009, 04:13:58 pm »
hmm, that one gives me an error when trying to run the game, roughly translated stating sth. like "program cannot start because intl.dll is missing on the computer" - that didn't happen with your earlier builds...

it works by putting the old intl.dll from the last build into the UFO AI folder, so i guess that one just got lost somewhere in the process of compiling the exe ;)

i'll attach it in case someone else is lacking it, too. Easier than downloading & installing the old one to get it i guess :D

Offline Zell65

  • Cannon Fodder
  • **
  • Posts: 2
    • View Profile
Re: Win32 Development Binary Installer Links
« Reply #299 on: September 13, 2009, 01:18:07 pm »
Due to a defect of my computer, I have a meager 20gig C drive, which has always hovered around 200-300 megs of free space. I can't feasibly get rid of anything since it's all the standard windows components (I've mistakenly removed wordpad and media player in my attempts to free enough space to operate, and I've taken to clearing my temp files regularly).  How can I change things so that the installer isn't writing the temp files it uses during the install to my broken little C drive since the installer fills the space fast and then can't continue extracting? I've already gotten stumped by the work involved in compiling the game myself... I'm not experienced with apps that require more than the simple running of an exe or an unzipping to use.

My other drive by the way is a perfectly normal 300gig drive (thank the geniuses at HP for that quirk)

Also, I didn't see any sort of rules thread so forgive if I've already erred in my first post ;)
and sorry if I sound ranting about the failings of my comp.

EDIT: Just wanted to clarify I'm 99% sure this is no failing of the developers or anyone else, just problems on my end that I don't know how to fix.

EDIT EDIT: Nevermind, I was able to track down and clear a 1 gig cache for another game, should be clear now. Just forget I was ever here, hehe.
« Last Edit: September 13, 2009, 01:55:13 pm by Zell65 »