project-navigation
Personal tools

Author Topic: RC3: Crashes: at start of game, at start of mission  (Read 2483 times)

HaJo

  • Guest
RC3: Crashes: at start of game, at start of mission
« on: July 22, 2006, 02:15:34 pm »
I tried to replay yesterdays mission, but the game keeps crashing:
* at start of game,
* when selecting the first mission (Revelstoke)

ufoconsole.log has nothing unusual:

Crash right after starting game:
Code: [Select]
Winsock Initialized
Console initialized.
------- Loading ref_gl32d.dll -------
ref_gl version: GL 0.12
Initializing OpenGL display
...setting mode 6: 1024 768 FS
...attempting fullscreen
...using desktop frequency: 0 hz
...using desktop display depth of 32
...calling CDS: ok
GL PFD: color(32-bits) Z(24-bit)
GL_VENDOR: NVIDIA Corporation
GL_RENDERER: GeForce2 GTS/AGP/SSE
GL_VERSION: 1.2.1
GL_EXTENSIONS: GL_ARB_multitexture GL_ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_transpose_matrix GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_compiled_vertex_array GL_EXT_fog_coord GL_EXT_packed_pixels GL_EXT_paletted_texture GL_EXT_point_parameters GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shared_texture_palette GL_EXT_stencil_wrap GL_EXT_texture_compression_s3tc GL_EXT_texture_edge_clamp GL_EXT_texture_env_add GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_cube_map GL_EXT_texture_filter_anisotropic GL_EXT_texture_lod GL_EXT_texture_lod_bias GL_EXT_texture_object GL_EXT_vertex_array GL_EXT_vertex_weighting GL_IBM_texture_mirrored_repeat GL_KTX_buffer_region GL_NV_blend_square GL_NV_fence GL_NV_fog_distance GL_NV_light_max_exponent GL_NV_register_combiners GL_NV_texgen_emboss GL_NV_texgen_reflection GL_NV_texture_env_combine4 GL_NV_vertex_array_range GL_S3_s3tc GL_SGIS_multitexture GL_SGIS_texture_lod GL_WIN_swap_hint WGL_EXT_swap_control GL_Autodesk_valid_back_buffer_hint
...enabling GL_EXT_compiled_vertex_array
...enabling WGL_EXT_swap_control
...using GL_EXT_point_parameters
...using GL_ARB_multitexture
...using GL_EXT_texture_env_combine
...GL_SGIS_multitexture deprecated in favor of ARB_multitexture
...ignoring GL_ARB_texture_compression
...using GL_EXT_texture_filter_anisotropic [ 2 max] [ 1 selected]
...using GL_EXT_texture_lod_bias
...using GL_EXT_stencil_wrap
...using GL_EXT_fog_coord
...GL_ARB_fragment_program not found
...GL_ATI_separate_stencil not found
...max texture size:
......detected 2048
...SDL_ttf inited
------------------------------------

------- sound initialization -------
Soundsystem: SDL.
SDL audio driver is "dsound".
Bits: 16
Frequency: 44100
Samples: 1024
Channels: 2
sound sampling rate: 44100
------------------------------------
CD Audio Initialized
couldn't exec autoexec.cfg
...could not set to language: en_GB
...could not set to system language
Shared Client/Server Info loaded
====== UFO Initialized ======

Changing to Singleplayer

 --> "Error: GLimp_EndFrame() - SwapBuffers() failed!"

Just in case the savegame could be bad, I started a new campaign,
but also got a crash when selecting the first mission:

Code: [Select]
...
====== UFO Initialized ======

Changing to Singleplayer
Latitude for mission 'frozen_industrial' is bigger than 90 NS (128)
...
Global data loaded
...aircraft inited
Team './base/save/current.mpt' saved.
Campaign 'slot3' saved.


No errormessage here, program just quits.
As yesterday, on Win98