project-navigation
Personal tools

Author Topic: Multiple sound cards  (Read 2894 times)

Offline Daedelus

  • Cannon Fodder
  • **
  • Posts: 1
    • View Profile
Multiple sound cards
« on: May 13, 2008, 08:33:31 am »
This isn't really a critical issue, but I'm having a slight problem with the game.  Everything seems to be working so far, from the shot distance in that I have tested, but I can't find any options to configure the game to make use of my primary sound card.  I've checked the forums and the wiki for any mention of sound configuration, and the buglist for any mention of sound issues.  I'm certain that it's just a configuration issue on my end, but I'm not sure where to configure it.  I've checked the config.cfg and looked through quake 2 console commands to no avail.

I'm currently running ubuntu 8.04

Code: [Select]
cat /proc/asound/cards
 0 [nForce2        ]: NFORCE - NVidia nForce2
                      NVidia nForce2 with ALC650F at irq 17
 1 [UART           ]: MPU-401 UART - MPU-401 UART
                      MPU-401 UART at 0x330, irq 10
 2 [Live           ]: EMU10K1 - SB Live 5.1
                      SB Live 5.1 (rev.7, serial:0x80641102) at 0xd000, irq 20

I'm trying to make it work with the nForce2, but it's stuck on the Live.
I haven't tried disabling the Live yet, as I would rather have the system work with both in, as I am trying to keep the Live card exclusive to the Mic and headphone set.

Any help on changing the default card con fig would be appreciated.

Thanks in advance,

Daedelus


brebs

  • Guest
Re: Multiple sound cards
« Reply #1 on: August 10, 2008, 10:59:03 pm »
In ~/.ufoai/yourversion/base/config.cfg, use a different ALSA PCM than "default":
Code: [Select]
set snd_device "default"Change it to e.g.:
Code: [Select]
set snd_device "ufo"
ALSA is set up in ~/.asoundrc - see ALSA FAQ. So to define a "ufo" ALSA PCM which the game uses:

Code: [Select]
pcm.ufo {
    type hw
    card 2
}
ctl.ufo {
    type hw           
    card 2
}