project-navigation
Personal tools

Author Topic: Graphic errors in front of Text [pic included]  (Read 3405 times)

xabbu83

  • Guest
Graphic errors in front of Text [pic included]
« on: May 01, 2008, 05:45:06 pm »
Hi,

I tried to run UFOAI on my Thinkpad X31 with Ubuntu 7.10 Gnome. Installation was no problem with the .run file. Then i started a new campain. In the beginning i think there was scrolling text which was covered by green Bars so i couldn't read it. Then the Worldmap looked good, so i was happy again. But when i wantet to read the mail the error was there again. Watch the Pic.

If you want information about my graphic-card-setup, then tell my what console-output i should post here.

Thanx
Xabbu

PS:
Here is the Consolemsg that starts with ufoai:
Code: [Select]
andreas@X31:~/ufoai$ ./ufoai

---- filesystem initialization -----
Adding game dir: ./base
Added packfile ./base/0base.pk3 (5 files)
Added packfile ./base/0maps.pk3 (461 files)
Added packfile ./base/0media.pk3 (8 files)
Added packfile ./base/0models.pk3 (1231 files)
Added packfile ./base/0music.pk3 (35 files)
Added packfile ./base/0pics.pk3 (1577 files)
Added packfile ./base/0snd.pk3 (131 files)
Added packfile ./base/0ufos.pk3 (73 files)
using /home/andreas/.ufoai/2.2.1/base for writing
Adding game dir: /home/andreas/.ufoai/2.2.1/base
execing default.cfg
execing config.cfg
execing keys.cfg

----- network initialization -------
libcurl/7.16.4 GnuTLS/1.6.3 zlib/1.2.3.3 libidn/1.0 initialized.

------ server initialization -------

----- console initialization -------
Console initialized.

------- video initialization -------
SDL version: 1.2.12
I: desktop depth: 32bpp
I: setting mode 6: 1024x768 (fullscreen: no)
I: got 8 bits of stencil
I: got 24 bits of depth buffer
I: got double buffer
I: got 8 bits for red
I: got 8 bits for green
I: got 8 bits for blue
GL_VENDOR: Tungsten Graphics, Inc.
GL_RENDERER: Mesa DRI Radeon 20061018 AGP 4x x86/MMX/SSE2 NO-TCL
GL_VERSION: 1.3 Mesa 7.0.1
GL_EXTENSIONS: GL_ARB_imaging GL_ARB_multisample GL_ARB_multitexture GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_mirrored_repeat GL_ARB_texture_rectangle GL_ARB_transpose_matrix GL_ARB_vertex_buffer_object GL_ARB_window_pos GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_logic_op GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_compiled_vertex_array GL_EXT_convolution GL_EXT_copy_texture GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_histogram GL_EXT_packed_pixels GL_EXT_polygon_offset GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_stencil_wrap GL_EXT_subtexture GL_EXT_texture GL_EXT_texture3D GL_EXT_texture_edge_clamp GL_EXT_texture_env_add GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_object GL_EXT_texture_rectangle GL_EXT_vertex_array GL_APPLE_packed_pixels GL_ATI_texture_env_combine3 GL_ATI_texture_mirror_once GL_IBM_rasterpos_clip GL_IBM_texture_mirrored_repeat GL_MESA_ycbcr_texture GL_MESA_window_pos GL_NV_blend_square GL_NV_light_max_exponent GL_NV_texture_rectangle GL_NV_texgen_reflection GL_OES_read_format GL_SGI_color_matrix GL_SGI_color_table GL_SGIS_generate_mipmap GL_SGIS_texture_border_clamp GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod
ignoring GL_EXT_LockArrays
using GL_ARB_multitexture
using GL_EXT_texture_env_combine
GL_SGIS_multitexture not found
using GL_ARB_texture_compression
using GL_EXT_texture_filter_anisotropic [16 max] [ 1 selected]
using GL_EXT_texture_lod_bias
using GL_EXT_stencil_wrap
using GL_EXT_fog_coord
GL_ATI_separate_stencil not found
GL_EXT_stencil_two_side not found
max texture size: detected 512
SDL_ttf version 2.0.9 - we need at least 2.0.7

------- sound initialization -------
SDL_mixer version: 1.2.8
...audio rate: 44100
...audio channels: 2
...driver: 'alsa'

--- save subsystem initialization --
added size subsystem (check ff)
added base subsystem (check 0)
added campaign subsystem (check 1)
added hospital subsystem (check 2)
added market subsystem (check 3)
added research subsystem (check 4)
added employee subsystem (check 5)
added aliencont subsystem (check 6)
added production subsystem (check 7)
added aircraft subsystem (check 8)
added messagesystem subsystem (check 9)
added stats subsystem (check a)
added nations subsystem (check b)
added transfer subsystem (check c)

----------- parse scripts ----------
Shared Client/Server Info loaded
... 94 items parsed
... 31 damage types parsed
... 52 map definitions parsed
... 25 equipment definitions parsed
... 10 inventory definitions parsed
... 22 team definitions parsed
S_Music_Start: Playing music: 'music/PsymongN3'
CL_LanguageInit()... language settings are stored in configuration: de
123 static models loaded
====== UFO Initialized ======

Switch grab input off
Changing to Singleplayer
Global data loaded - size 5204572 bytes
...techs: 166
...buildings: 21
...ranks: 16
...nations: 8

Activate stage intro
Sanity check for script data
...buildings ok
...tech ok
...aircraft ok
...menu ok
S_Music_Start: Playing music: 'music/van_geoscape'
Save user settings to /home/andreas/.ufoai/2.2.1/base/config.cfg
recursive shutdown

PPS.: Ok, I think it is because of my graphic drivers, because my whole system crashes after some lookaround in the 3D environments. I will try to install other drivers tonight.

CU
Xabbu

[attachment deleted by admin]
« Last Edit: May 01, 2008, 06:24:28 pm by xabbu83 »

redliner777

  • Guest
Re: Graphic errors in front of Text [pic included]
« Reply #1 on: July 25, 2008, 08:00:30 pm »
I'm running Ubuntu on a Thinkpad T30 and am getting the exact same text issues. Are there any ideas on how to correct this?

Offline Mattn

  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4831
  • https://github.com/mgerhardy/vengi
    • View Profile
    • Vengi Voxel Tools
Re: Graphic errors in front of Text [pic included]
« Reply #2 on: July 25, 2008, 08:36:15 pm »
try to use the closed drivers for your ati card.

redliner777

  • Guest
Re: Graphic errors in front of Text [pic included]
« Reply #3 on: July 31, 2008, 11:19:47 pm »
I've looked for some time now, and can find no other drivers for my thinkpad. I'm getting close to just trying to run the windows version under wine lol

redliner777

  • Guest
Re: Graphic errors in front of Text [pic included] SOLVED
« Reply #4 on: July 31, 2008, 11:27:35 pm »
I installed driconf and changed some the "Support larger textures" setting to "announce hardware limits"