project-navigation
Personal tools

Author Topic: linux problems, no language  (Read 6896 times)

Offline geever

  • Project Coder
  • PHALANX Commander
  • ***
  • Posts: 2561
    • View Profile
linux problems, no language
« on: February 05, 2008, 06:56:42 pm »
Hi,

I've found your game last week. Let me gratulate, it's very good!

However I have some trouble with the linux version:
First I've downloaded the "installer" which didn't run. It was complaining about missing curl4 library. I have a Debian stable (4.0) system which contains only curl3. I tried to make a symlink on the library which seemed to work at least for this problem. The next was about GLIBC2.4... At this point I've decided to compile it for my system.

I downloaded the latest 2.2 source from svn, compiled it (configure;make;make install), then unpacked the ufoai-data package to the requested dir. I've started the game. Works, just the language is 'No Language', and there are no more options in the menu. The language files exists, in /usr/local/share/ufoai/base/i18n just the game can't recognize them, maybe. Can you help me solving this problem?

Thanks,
Geever

Offline BTAxis

  • Administrator
  • PHALANX Commander
  • *******
  • Posts: 2607
    • View Profile
Re: linux problems, no language
« Reply #1 on: February 05, 2008, 06:57:37 pm »
You can do make lang to compile the language files. I think.

Offline geever

  • Project Coder
  • PHALANX Commander
  • ***
  • Posts: 2561
    • View Profile
Re: linux problems, no language
« Reply #2 on: February 05, 2008, 07:15:11 pm »
I did it and make install seems to do it too but no effect.

Should I compile the maps or there are compiled versions (most) of them in the data package? Because map compilation is too slow... I tried to compile them once but stopped after 6hours(!!)  (I had to go work.) I have an Athlon XP 2000+ (eff.1667Mhz) w. 1G ram should it take more than 6 hours to compile the maps on it? Can this cause the language problem?

Offline Mattn

  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4831
  • https://github.com/mgerhardy/vengi
    • View Profile
    • Vengi Voxel Tools
Re: linux problems, no language
« Reply #3 on: February 05, 2008, 07:29:15 pm »
Quote
Should I compile the maps or there are compiled versions (most) of them in the data package?

There are - see our sourceforge.net download mirrors http://sourceforge.net/project/showfiles.php?group_id=157793

Quote
I have an Athlon XP 2000+ (eff.1667Mhz) w. 1G ram should it take more than 6 hours to compile the maps on it?

yes

Quote
Can this cause the language problem?

no

Offline Schmorgluck

  • Cannon Fodder
  • **
  • Posts: 8
    • View Profile
Re: linux problems, no language
« Reply #4 on: February 06, 2008, 05:17:11 pm »
Well, typing "make lang" simply doesn't work if you have not performed certain actions that I can't describe here because I can't find what they are, since they are not explained in the wiki or anywhere else I've looked for.

It seems we're supposed to guess.
« Last Edit: February 06, 2008, 05:19:00 pm by Schmorgluck »

Offline geever

  • Project Coder
  • PHALANX Commander
  • ***
  • Posts: 2561
    • View Profile
Re: linux problems, no language
« Reply #5 on: February 06, 2008, 07:14:07 pm »
Well, at last I've found the root of the problem: My system is Hungarian (locale hu_HU.UTF-8) and as there was no language for this locale none could be used.

If i put this locale to 'en' section of language.ufo I can select it from the menu however there are no texts for difficulty info, intro, etc. (just msgid)

I've started to make a Hungarian translation, put it in i18n, made 'hu' setting in language.ufo. Now I can select Hungarian, ok. But I left the hu_HU.UTF8 locale in English section too and if I select English the game turns into Hungarian. So it seems there is a bug somewhere in the language handling. Maybe (but I didn't check it) the first two char of the locale was used as language-id not the section name...

Why I can't use other language than my locale setting? (Others are not even shown in the menu.)

vlad

  • Guest
Re: linux problems, no language
« Reply #6 on: February 12, 2008, 09:17:48 pm »
Well, at last I've found the root of the problem: My system is Hungarian (locale hu_HU.UTF-8) and as there was no language for this locale none could be used.

If i put this locale to 'en' section of language.ufo I can select it from the menu however there are no texts for difficulty info, intro, etc. (just msgid)
$LANG=en.UTF-8 ufo &
Work fo me.

Offline geever

  • Project Coder
  • PHALANX Commander
  • ***
  • Posts: 2561
    • View Profile
Re: linux problems, no language
« Reply #7 on: February 12, 2008, 09:58:12 pm »
Quote
$LANG=en.UTF-8 ufo &
Do you mean 'export LANG=en.UTF-8;ufo' ?
Because setting LANG env. changed my locale to english (in the output of locale program), but the game worked the same way: English cannot be selected only No language and Hungarian.

In Windows I can select English and other languages, and it's Hungarian too. ??

geever.

vlad

  • Guest
Re: linux problems, no language
« Reply #8 on: February 12, 2008, 10:30:23 pm »
Do you mean 'export LANG=en.UTF-8;ufo' ?
Because setting LANG env. changed my locale to english (in the output of locale program), but the game worked the same way: English cannot be selected only No language and Hungarian.

There is no need export LANG. Setting it (more precisely LC_MESSAGES) for ufo process is enough. I can see and switch to a different languages, but if I don't set LANG to appropriate locale, I still don't see the messages.

$uname -rs
FreeBSD 6.3-RELEASE
$echo $LANG
uk_UA.UTF-8
$pkg_info -L ufoai-2.2
Information for ufoai-2.2:

Files:
/usr/local/bin/ufo
/usr/local/bin/ufoded
/usr/local/bin/ufo2map
/usr/local/lib/ufoai/base/game.so
/usr/local/lib/ufoai/base/i18n/cs/LC_MESSAGES/ufoai.mo
/usr/local/lib/ufoai/base/i18n/da/LC_MESSAGES/ufoai.mo
/usr/local/lib/ufoai/base/i18n/de/LC_MESSAGES/ufoai.mo
/usr/local/lib/ufoai/base/i18n/en/LC_MESSAGES/ufoai.mo
/usr/local/lib/ufoai/base/i18n/es/LC_MESSAGES/ufoai.mo
/usr/local/lib/ufoai/base/i18n/es_ES/LC_MESSAGES/ufoai.mo
/usr/local/lib/ufoai/base/i18n/est/LC_MESSAGES/ufoai.mo
/usr/local/lib/ufoai/base/i18n/fi/LC_MESSAGES/ufoai.mo
/usr/local/lib/ufoai/base/i18n/fr/LC_MESSAGES/ufoai.mo
/usr/local/lib/ufoai/base/i18n/ja/LC_MESSAGES/ufoai.mo
/usr/local/lib/ufoai/base/i18n/it/LC_MESSAGES/ufoai.mo
/usr/local/lib/ufoai/base/i18n/pl/LC_MESSAGES/ufoai.mo
/usr/local/lib/ufoai/base/i18n/pt_BR/LC_MESSAGES/ufoai.mo
/usr/local/lib/ufoai/base/i18n/ru/LC_MESSAGES/ufoai.mo
/usr/local/lib/ufoai/base/i18n/slo/LC_MESSAGES/ufoai.mo
/usr/local/lib/ufoai/base/i18n/sv/LC_MESSAGES/ufoai.mo
/usr/local/lib/ufoai/base/i18n/th/LC_MESSAGES/ufoai.mo
/usr/local/lib/ufoai/ufo
/usr/local/lib/ufoai/ufoded
/usr/local/lib/ufoai/ufo2map
/usr/local/lib/ufoai/base/autoexec.cfg
/usr/local/lib/ufoai/base/dedicated.cfg
/usr/local/lib/ufoai/base/default.cfg
/usr/local/lib/ufoai/base/keys.cfg
/usr/local/lib/ufoai/base/maps
/usr/local/lib/ufoai/base/media
/usr/local/lib/ufoai/base/models
/usr/local/lib/ufoai/base/music
/usr/local/lib/ufoai/base/pics
/usr/local/lib/ufoai/base/shaders
/usr/local/lib/ufoai/base/sound
/usr/local/lib/ufoai/base/textures
/usr/local/lib/ufoai/base/ufos

Offline geever

  • Project Coder
  • PHALANX Commander
  • ***
  • Posts: 2561
    • View Profile
Re: linux problems, no language
« Reply #9 on: February 12, 2008, 11:57:34 pm »
I thought '$' sign before LANG was a variable-sign, but now I can see that's a prompt-sign... (putting a space between prompt-sign and the command could make it clear, or using '#')

I couldn't select any languages.
After setting LANG=en.UTF-8 a `locale' request gave me some errors:
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory

...ops, I've found something: my /etc/locale.gen file contained :'hu_HU.UTF-8 UTF-8'. After added 'en_GB.UTF-8 UTF-8' and run the locale-gen the English language appeared in the game and English texts were correct. wow! :)