project-navigation
Personal tools

Author Topic: 2.3-dev compile map problem  (Read 3336 times)

xtatuk

  • Guest
2.3-dev compile map problem
« on: January 27, 2008, 01:28:19 am »
2.3-dev compile map problem

Hello, just thought I would try this game out, got some problem while compiling. 

I am using Linux Ubuntu 7.10 desktop with Kernel 2.6.22-14, Processor Intel Core 2 Duo, Graphic Card Nvidia 8800GTX using 169.09 drivers.

I followed the instructions at "Compiling the source - Debian/Ubuntu", downloaded latest game version using SVN, "2.3-dev Updated to revision 14253"

... Had no problem with ...

./configure
make -j 4
make lang -j 4

... But when trying to do ...

make maps -j 4

... I get errors.

entering /media/sdd1/Software/Linux/SVN/ufoai/trunk/base/maps/druglord07d.map

************ ERROR ************
Brush 58 (entity 0) has invalid mix of stepon and actorclip
extrasamples = true
make[1]: *** [stadium06d.bsp] Error 1
path: 'africa04d.map'
make[1]: *** Waiting for unfinished jobs....

... Then I tried ...

cd base/maps
make -j 4

../../ufo2map -nice 19 -extra stadium06d.map
---- ufo2map 1.1 ----
nice = 19
extrasamples = true
path: 'stadium06d.map'
gamedir: /media/sdd1/Software/Linux/SVN/ufoai/trunk/base/
Added packfile /media/sdd1/Software/Linux/SVN/ufoai/trunk/base/0pics.pk3 (1611 files)
...map: '/media/sdd1/Software/Linux/SVN/ufoai/trunk/base/maps/stadium06d.map'
...bsp: '/media/sdd1/Software/Linux/SVN/ufoai/trunk/base/maps/stadium06d.bsp'
entering /media/sdd1/Software/Linux/SVN/ufoai/trunk/base/maps/stadium06d.map

************ ERROR ************
Brush 58 (entity 0) has invalid mix of stepon and actorclip
make: *** [stadium06d.bsp] Error 1

... Just to make sure I have latest CVS version, I did a "svn up" in trunk dir but no file has changed.

... Tried run archives.sh in /base/ directory ...

generating archives

pics and textures...
models...
sound...
music...
maps...
  adding: maps/icen/ice_drop.bsp (deflated 78%)
  adding: maps/icen/ice_r02.bsp (deflated 79%)
  adding: maps/icen/ice_r04.bsp (deflated 78%)
videos...
        zip warning: 0videos.pk3 not found or empty
media...
i18n...
don't include this in the zipfiles - gettext doesn't have support for it
ufos...
materials...
base...
...finished

... Tried anyway to run the game, ./ufo, it starts without problem and I managed to start a single player campaign, but when trying to do ground missions, nothing happends, game just continue but i never start mission. Here is history from the console ...

---- filesystem initialization -----
Adding game dir: ./base
Added packfile ./base/0base.pk3 (4 files)
Added packfile ./base/0maps.pk3 (25 files)
Added packfile ./base/0materials.pk3 (6 files)
Added packfile ./base/0media.pk3 (11 files)
Added packfile ./base/0models.pk3 (1238 files)
Added packfile ./base/0music.pk3 (35 files)
Added packfile ./base/0pics.pk3 (1611 files)
Added packfile ./base/0snd.pk3 (130 files)
Added packfile ./base/0ufos.pk3 (74 files)
using /home/xtatuk/.ufoai/2.3-dev/base for writing
Adding game dir: /home/xtatuk/.ufoai/2.3-dev/base
execing default.cfg
execing config.cfg
execing keys.cfg

----- network initialization -------
libcurl/7.16.4 OpenSSL/0.9.8e zlib/1.2.3.3 libidn/1.0 initialized.

------ server initialization -------
added 3 maps to the mapcycle

----- console initialization -------
Console initialized.

------- video initialization -------
SDL version: 1.2.11
I: desktop depth: 32bpp
I: video memory: 0
I: video driver: x11
I: setting mode 6: 1024x768 (fullscreen: no)
I: got 8 bits of stencil
I: got 24 bits of depth buffer
I: got double buffer
I: got 8 bits for red
I: got 8 bits for green
I: got 8 bits for blue
I: got 0 bits for alpha
... ... ...
max texture size: detected 8192
but using 2048 as requested
SDL_ttf version 2.0.9 - we need at least 2.0.7

------- sound initialization -------
SDL_mixer version: 1.2.6
...audio rate: 44100
...audio channels: 2
...driver: 'alsa'

--- save subsystem initialization --
added size subsystem (check ff)
added base subsystem (check 0)
added campaign subsystem (check 1)
added hospital subsystem (check 2)
added market subsystem (check 3)
added research subsystem (check 4)
added employee subsystem (check 5)
added aliencont subsystem (check 6)
added production subsystem (check 7)
added aircraft subsystem (check 8)
added messagesystem subsystem (check 9)
added stats subsystem (check a)
added nations subsystem (check b)
added transfer subsystem (check c)

----------- parse scripts ----------
Shared Client/Server Info loaded
... 94 items parsed
... 31 damage types parsed
... 52 map definitions parsed
... 26 equipment definitions parsed
... 10 inventory definitions parsed
... 22 team definitions parsed
CL_LanguageInit()... language settings are stored in configuration: en
123 static models loaded
...uploaded 5 shaders
====== UFO Initialized ======

execing autoexec.cfg
"version" is "UFO: Alien Invasion 2.3-dev i386 Jan 26 2008 Linux DEBUG"
Switch grab input off
S_Music_Start: Playing music: 'music/PsymongN3'
Loading savegame
...version: 3
...game version: 2.3-dev
Changing to Singleplayer
Global data loaded - size 5255836 bytes
...techs: 167
...buildings: 22
...ranks: 16
...nations: 8

Load 'slot0'
...subsystem 'size' - loaded 101 bytes
...subsystem 'base' - loaded 13019 bytes
Activate stage intro
......warning: Set with no missions (stop)
...subsystem 'campaign' - loaded 256 bytes
...subsystem 'hospital' - loaded 0 bytes
...subsystem 'market' - loaded 2899 bytes
...subsystem 'research' - loaded 7978 bytes
...subsystem 'employee' - loaded 13937 bytes
...subsystem 'aliencont' - loaded 0 bytes
...subsystem 'production' - loaded 8 bytes
...subsystem 'aircraft' - loaded 353 bytes
...subsystem 'messagesystem' - loaded 705 bytes
...subsystem 'stats' - loaded 28 bytes
...subsystem 'nations' - loaded 1248 bytes
...subsystem 'transfer' - loaded 86400 bytes
File 'slot0' loaded.
Changing to Singleplayer
S_Music_Start: Playing music: 'music/van_geoscape'
Save 'slotquick'
...subsystem 'size' - saved 101 bytes
...subsystem 'base' - saved 13187 bytes
...subsystem 'campaign' - saved 330 bytes
...subsystem 'hospital' - saved 0 bytes
...subsystem 'market' - saved 2899 bytes
...subsystem 'research' - saved 7978 bytes
...subsystem 'employee' - saved 13937 bytes
...subsystem 'aliencont' - saved 0 bytes
...subsystem 'production' - saved 8 bytes
...subsystem 'aircraft' - saved 353 bytes
...subsystem 'messagesystem' - saved 795 bytes
...subsystem 'stats' - saved 28 bytes
...subsystem 'nations' - saved 1248 bytes
...subsystem 'transfer' - saved 86400 bytes
Campaign 'QuickSave' saved.
------- Loading game.so -------
LoadLibrary (./base/game.so)
==== InitGame ====
CM_LoadMap: "-orientaln/or_ +h03 +h04 +h08 +drop +h11 +h01 +h04 +h15 +h07 +h15 +h12 +h07" "8 0 0 -16 -16 -8 -16 8 -16 -24 8 16 8 -24 0 -24 0 0 0 -8 16 -8 16 0"
Couldn't load maps/orientaln/or_h03.bsp
********************
ERROR: Couldn't load maps/orientaln/or_h03.bsp
********************
==== ShutdownGame ====
Save user settings to /home/patrick/.ufoai/2.3-dev/base/config.cfg
recursive shutdown

... Not sure if I have done anything, but it would be good to begin the ground missions as well to really enjoy the game.

xTatuk, Nottingham, UK

Offline Mattn

  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4831
  • https://github.com/mgerhardy/vengi
    • View Profile
    • Vengi Voxel Tools
Re: 2.3-dev compile map problem
« Reply #1 on: January 27, 2008, 09:07:29 am »
yes, this is related - if there are more maps that have the same problem with
Code: [Select]
Brush x (entity 0) has invalid mix of stepon and actorclip please let us know

xtatuk

  • Guest
Re: 2.3-dev compile map problem
« Reply #2 on: January 27, 2008, 11:11:53 am »
Thanks for replay...

I did a "svn up" in trunk dir this morning, got Updated to revision 14255 but when trying to compile the maps again...

cd base/maps
make -j 4

../../ufo2map -nice 19 -extra industrial06d.map
---- ufo2map 1.1 ----
nice = 19
extrasamples = true
path: 'industrial06d.map'
gamedir: /media/sdd1/Software/Linux/SVN/ufoai/trunk/base/
Added packfile /media/sdd1/Software/Linux/SVN/ufoai/trunk/base/0pics.pk3 (1611 files)
...map: '/media/sdd1/Software/Linux/SVN/ufoai/trunk/base/maps/industrial06d.map'
...bsp: '/media/sdd1/Software/Linux/SVN/ufoai/trunk/base/maps/industrial06d.bsp'
entering /media/sdd1/Software/Linux/SVN/ufoai/trunk/base/maps/industrial06d.map

************ ERROR ************
Brush 0 (entity 0) has invalid mix of stepon and actorclip
make: *** [industrial06d.bsp] Error 1
make: *** Waiting for unfinished jobs....

... get errors about another bsp file.
... I will try to run "svn up" later today and recompile.

xtatuk

  • Guest
Re: 2.3-dev compile map problem
« Reply #3 on: January 27, 2008, 05:22:58 pm »
... did a update again today during afternoon, "Updated to revision 14268" ...

make -j 4

../../ufo2map -nice 19 -extra oriental06n.map
---- ufo2map 1.1 ----
nice = 19
extrasamples = true
path: 'oriental06n.map'
gamedir: /media/sdd1/Software/Linux/SVN/ufoai/trunk/base/
Added packfile /media/sdd1/Software/Linux/SVN/ufoai/trunk/base/0pics.pk3 (1611 files)
...map: '/media/sdd1/Software/Linux/SVN/ufoai/trunk/base/maps/oriental06n.map'
...bsp: '/media/sdd1/Software/Linux/SVN/ufoai/trunk/base/maps/oriental06n.bsp'
entering /media/sdd1/Software/Linux/SVN/ufoai/trunk/base/maps/oriental06n.map
Entity 0, Brush 74: optimized detail
Entity 0, Brush 82: optimized detail
Entity 0, Brush 89: optimized detail

************ ERROR ************
Brush 236 (entity 0) has invalid mix of stepon and actorclip
make: *** [oriental06n.bsp] Error 1
make: *** Waiting for unfinished jobs....

... will try again later today.

xtatuk

  • Guest
Re: 2.3-dev compile map problem
« Reply #4 on: January 27, 2008, 05:46:45 pm »
... That was a quick one, did a update to "revision 14274" atm and tried again.

../../ufo2map -nice 19 -extra b/workshop.map
---- ufo2map 1.1 ----
nice = 19
extrasamples = true
path: 'b/workshop.map'
gamedir: /media/sdd1/Software/Linux/SVN/ufoai/trunk/base/
Added packfile /media/sdd1/Software/Linux/SVN/ufoai/trunk/base/0pics.pk3 (1611 files)
...map: '/media/sdd1/Software/Linux/SVN/ufoai/trunk/base/maps/b/workshop.map'
...bsp: '/media/sdd1/Software/Linux/SVN/ufoai/trunk/base/maps/b/workshop.bsp'
entering /media/sdd1/Software/Linux/SVN/ufoai/trunk/base/maps/b/workshop.map

************ ERROR ************
Brush 246 (entity 0) has invalid mix of stepon and actorclip
make: *** [b/workshop.bsp] Error 1
make: *** Waiting for unfinished jobs....

... Should I just keep posting the errors I encounter here on this place ? or do you have another way of bug reports.

// xtatuk.

Offline Mattn

  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4831
  • https://github.com/mgerhardy/vengi
    • View Profile
    • Vengi Voxel Tools
Re: 2.3-dev compile map problem
« Reply #5 on: January 27, 2008, 06:29:17 pm »
report them when you find them - we try to fix them in the meantime

xtatuk

  • Guest
Re: 2.3-dev compile map problem
« Reply #6 on: January 27, 2008, 07:54:50 pm »
... Ok, I will keep posting ...

... Updated to revision 14282 ...

../../ufo2map -nice 19 -extra b/hospital.map
---- ufo2map 1.1 ----
nice = 19
extrasamples = true
path: 'b/hospital.map'
gamedir: /media/sdd1/Software/Linux/SVN/ufoai/trunk/base/
Added packfile /media/sdd1/Software/Linux/SVN/ufoai/trunk/base/0pics.pk3 (1611 files)
...map: '/media/sdd1/Software/Linux/SVN/ufoai/trunk/base/maps/b/hospital.map'
...bsp: '/media/sdd1/Software/Linux/SVN/ufoai/trunk/base/maps/b/hospital.bsp'
entering /media/sdd1/Software/Linux/SVN/ufoai/trunk/base/maps/b/hospital.map

************ ERROR ************
Brush 2 (entity 0) has invalid mix of stepon and actorclip
make: *** [b/hospital.bsp] Error 1
make: *** Waiting for unfinished jobs....


xtatuk

  • Guest
Re: 2.3-dev compile map problem
« Reply #7 on: January 28, 2008, 07:55:42 pm »
... I updated today to version 14283, and completely managed to compile /base/maps by make -j 4, it took couple of hours. Whoho now I can play the dev version of the game. Thanks!