project-navigation
Personal tools

Author Topic: No textures displaying - old PC  (Read 2624 times)

JimiD

  • Guest
No textures displaying - old PC
« on: January 26, 2008, 07:25:18 pm »
Just downloaded, and it all installed well, and plays fine.

Just looks like an arctic world - white planet, grey shapes for people and aircraft in geoscape, and a white environment in battlescape - with shadows and definition, so it can be played, just doesnt looks like the screenshots.

I have an old PC:

P2 400
128 mb RAM
Win 98
Nvidia RIVA TNT

So I suspect the issue is that the card can't handle OpenGL properly / to a suitable level, but the other option is that I haven't installed the texture files.  I am pretty sure the driver is upto date, because they havent been bringing out new drivers for a while now.

I didnt see a guide that suggested installing anything other than the windows .exe file, but I might have overlooked it of course.

So if I have failed to install properly, or done something else stupid, please let me know.  If it is the old card / system, I guess I'll have to make to playing in the arctic, at least at the moment.



log file below:
(which seems to include data about my first game, which didnt go so well, lesson leant no.1 - dont send an interceptor with a single soldier to the first incident...)

Quote
----- network initialization -------
libcurl/7.16.4 zlib/1.2.2 initialized.

------ server initialization -------

----- console initialization -------
Console initialized.

------- video initialization -------
SDL version: 1.2.11
I: desktop depth: 16bpp
I: setting mode 6: 1024x768 (fullscreen: yes)
I: got 8 bits of stencil
I: got 16 bits of depth buffer
I: got double buffer
I: got 5 bits for red
I: got 6 bits for green
I: got 5 bits for blue
GL_VENDOR: NVIDIA Corporation
GL_RENDERER: RIVA TNT (AGP)
GL_VERSION: 1.1.2
GL_EXTENSIONS: GL_ARB_multitexture GL_EXT_abgr GL_EXT_bgra GL_EXT_clip_volume_hint GL_EXT_compiled_vertex_array GL_EXT_cull_vertex GL_EXT_packed_pixels GL_EXT_point_parameters GL_EXT_stencil_wrap GL_EXT_texture_object GL_EXT_vertex_array GL_KTX_buffer_region GL_SGIS_multitexture GL_NV_texgen_reflection GL_WIN_swap_hint
ignoring GL_EXT_LockArrays
ignoring GL_ARB_multitexture
GL_EXT_texture_env_combine not found
ignoring GL_SGIS_multitexture
GL_ARB_texture_compression not found
GL_EXT_texture_filter_anisotropic not found
GL_EXT_texture_lod_bias not found
using GL_EXT_stencil_wrap
GL_EXT_fog_coord not found
GL_ATI_separate_stencil not found
GL_EXT_stencil_two_side not found
max texture size: cannot detect - using 1024!
SDL_ttf version 2.0.7 - we need at least 2.0.7

------- sound initialization -------
not initializing.

--- save subsystem initialization --
added size subsystem (check ff)
added base subsystem (check 0)
added campaign subsystem (check 1)
added hospital subsystem (check 2)
added market subsystem (check 3)
added research subsystem (check 4)
added employee subsystem (check 5)
added aliencont subsystem (check 6)
added production subsystem (check 7)
added aircraft subsystem (check 8)
added messagesystem subsystem (check 9)
added stats subsystem (check a)
added nations subsystem (check b)
added transfer subsystem (check c)

----------- parse scripts ----------
Shared Client/Server Info loaded
... 94 items parsed
... 31 damage types parsed
... 52 map definitions parsed
... 25 equipment definitions parsed
... 10 inventory definitions parsed
... 22 team definitions parsed
CL_LanguageInit()... language settings are stored in configuration: en
123 static models loaded
====== UFO Initialized ======

Priority changed to HIGH
Found 1 processors
...only use one processor
Switch grab input off
Restarting sound

------- sound initialization -------
SDL_mixer version: 1.2.8
...audio rate: 44100
...audio channels: 2
...driver: 'dsound'
S_Music_Start: Playing music: 'music/PsymongN3'
Changing to Singleplayer
Global data loaded - size 5204572 bytes
...techs: 165
...buildings: 21
...ranks: 16
...nations: 8

Changing to Singleplayer
Activate stage intro
Sanity check for script data
...buildings ok
...tech ok
...aircraft ok
...menu ok
Changing to Singleplayer
S_Music_Start: Playing music: 'music/van_geoscape'
R_FindImage: Can't find models/geoscape//base (models/geoscape//base)
Save 'slotquick'
...subsystem 'size' - saved 101 bytes
...subsystem 'base' - saved 13446 bytes
...subsystem 'campaign' - saved 326 bytes
...subsystem 'hospital' - saved 0 bytes
...subsystem 'market' - saved 2899 bytes
...subsystem 'research' - saved 7882 bytes
...subsystem 'employee' - saved 5617 bytes
...subsystem 'aliencont' - saved 0 bytes
...subsystem 'production' - saved 141 bytes
...subsystem 'aircraft' - saved 353 bytes
...subsystem 'messagesystem' - saved 1912 bytes
...subsystem 'stats' - saved 28 bytes
...subsystem 'nations' - saved 1248 bytes
...subsystem 'transfer' - saved 86400 bytes
Campaign 'QuickSave' saved.
==== InitGame ====
checksum for the map '+orientald': 2047088918
ufo script checksum 1002310734
Created AI player (team 0)
Created AI player (team 7)
-------------------------------------
Connecting to localhost...
Map: +orientald
S_Music_Start: Playing music: 'music/van_mission'
Starting the game...
 has joined team 0
(player 0) It's team 1's round
 has taken control over team 1.
S_Music_Start: Playing music: 'music/van_geoscape'
Team 1 ended round, team 7's round started!
Team 7 ended round, team 0's round started!
Team 0 ended round, team 1's round started!
Team 1 ended round, team 7's round started!
Team 7 ended round, team 0's round started!
Team 0 ended round, team 1's round started!
Team 1 ended round, team 7's round started!
Team 7 ended round, team 1's round started!
Team 1 ended round, team 7's round started!
[STATS] 2008/01/26 15:56:53 - End of game - Team 7 is the winner
[STATS] 2008/01/26 15:56:53 - End of game - Team 7 is the winner
==== ShutdownGame ====
S_Music_Start: Playing music: 'music/ufo2'
S_Music_Start: Playing music: 'music/van_geoscape'
Save user settings to C:\WINDOWS\Application Data\UFOAI/2.2/base/config.cfg



Thanks for the help, and the game

Offline Mattn

  • CaveExpress
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4830
  • www.caveproductions.org
    • View Profile
    • CaveExpress
Re: No textures displaying - old PC
« Reply #1 on: January 27, 2008, 03:44:02 pm »
try to activate multitexturing (should be an option in the 2.2 video menu afair)
otherwise it's the cvar r_ext_multitexture - set it to 1

JimiD

  • Guest
Re: No textures displaying - old PC
« Reply #2 on: January 28, 2008, 02:46:19 pm »
Thanks for the prompt reply.

Having so confidently stated I had the most upto date drivers, I must eat my words, as I found a more upto date patch, for a whole list of Nvidia cards, from 2005.  I thought I had reformatted recently, but upon reflection, this might have been 3-4 years ago.  Time flies...

So I have solved this with the obvious, and am posting more to say thanks and to provide an answer to the problem, which seems similar to the one described in this link.

Unfortunately the update patch has left me with another, non-critical error - "NvCPL.dll cant load due to missing libraries".  Didnt know I was missing it before, and not loading it doesnt seem to have any effect on my PC.  A warning just pops up stating it has not loaded, click OK, and carry on as before.  Irritating, but not the end of the world.

I have tried reinstalling the original drivers to get rid of it, without success.  It appears to be a Nvidia console, presumably for adjusting the display properties, which is still possible through the Control Panel.  I guess I need to find out where is loads in the boot process and delete it, but I cant seem to find it.

Not quite the right place to be asking for help, but you never know...

Anyway, game plays very well thank you.

I played through the first two action scenes (getting 5 soldiers killed in the process) before the
Aircraft Production Bug caused me to stop for the night - should have been saving more regularly

And I have a painfully slow mouse, but I see a solution a couple of posts below me, so will have to have a look tonight if that works.  Or if its just a lack of RAM.