project-navigation
Personal tools

Author Topic: Trouble starting 2.2  (Read 50702 times)

Dream Worker

  • Guest
Re: Trouble starting 2.2
« Reply #30 on: February 04, 2008, 08:26:54 am »
My solution
1.
Quote
put colors in 16 bit instead of 32 bit
I started the game but it run windowed. Hmm, I tryed to run Safe Mode - ok but no sound.
I looked at parameters of a command line of Safe Mode Icon: +set vid_fullscreen 1 +set r_mode 6 +set snd_init 0
2. I have changed cmd line parametres to
"C:\Program Files\UFOAI-2.2\ufo.exe" +set vid_fullscreen 1 +set r_mode 6 +set snd_init 1"
Now game works properly.
ATI Radeon Sapphire HD 2600 Pro
Catalyst 07.7
(тоже из России)

luuckke

  • Guest
Re: Trouble starting 2.2
« Reply #31 on: February 06, 2008, 04:56:55 am »
hello!!

im a new player of UFOAI !!! i Congatulate you all, its really getting to be a great game.
a version called UFO: EXTRATERRESTRIALS were created... but its just a remake with more beautiful graphics... you are great!

i got the same problem as the first guy in this topic... but i have a GeForce FX 5200
simply changing to 16bit didnt work.... any idea of what can i do?

thanks

Rabbit

  • Guest
Re: Trouble starting 2.2
« Reply #32 on: February 06, 2008, 01:27:05 pm »
          Re: Trouble starting 2.2
Quote
put colors in 16 bit instead of 32 bit
I started the game but it run windowed. Hmm, I tryed to run Safe Mode - ok but no sound.
I looked at parameters of a command line of Safe Mode Icon: +set vid_fullscreen 1 +set r_mode 6 +set snd_init 0
2. I have changed cmd line parametres to
"C:\Program Files\UFOAI-2.2\ufo.exe" +set vid_fullscreen 1 +set r_mode 6 +set snd_init 1"
Now game works properly.
ATI Radeon Sapphire HD 2600 Pro
Catalyst 07.7
(тоже из России)[/quote]

Thanks for the decision. (короче по русски напишу). спасобо земляк, я уже сам до его реализации дошел, а вот в командной строке, только узнал, еще раз thanks very much.
На деюсь наши зарубежные друзья модераторы, злиться не будут, они же ("буржуи") самые толерантные и добрые ;)
« Last Edit: February 06, 2008, 01:33:59 pm by Rabbit »

Offline Redtide

  • Rookie
  • ***
  • Posts: 34
    • View Profile
Re: Trouble starting 2.2
« Reply #33 on: February 13, 2008, 06:16:09 pm »
Found a FIX :D

Short tutorial:

1. U need catalyst drivers installiation package <=7.9
2. Start it, and dont press any buttons and dont' install it (u just need some file that will be unpacked ;) )
3. Go to c:\ATI\SUPPORT\7-8_xp32_dd_50960\Driver\XP_INF\B_51322\ (example for 7.8 )
4. Copy atioglxx.dl_ to another directory
5. Use in cmd.exe this command:

expand atioglxx.dl_ atioglxx.dll


6. Copy atioglxx.dll to UFO directory
7. Enjoy ;)

Tested by me on 7.12 and 8.1 :)

What exactly do u mean by copy to another directory?
« Last Edit: February 13, 2008, 06:18:03 pm by Redtide »

Offline Redtide

  • Rookie
  • ***
  • Posts: 34
    • View Profile
Re: Trouble starting 2.2
« Reply #34 on: February 14, 2008, 08:39:10 pm »
I tried this and it said "can't open input file: atioglxx.dl_

Offline BTAxis

  • Administrator
  • PHALANX Commander
  • *******
  • Posts: 2607
    • View Profile
Re: Trouble starting 2.2
« Reply #35 on: February 14, 2008, 08:41:11 pm »
You probably didn't do the expand step.

Offline Redtide

  • Rookie
  • ***
  • Posts: 34
    • View Profile
Re: Trouble starting 2.2
« Reply #36 on: February 15, 2008, 02:03:54 am »
Actually that is what step I'm doing when I get the error. Is there a specific place I should put the file before I expand it?

Starship_Yard

  • Guest
Re: Trouble starting 2.2
« Reply #37 on: March 05, 2008, 12:02:49 am »
Thanks Fixer!  That fixed my problem with updated Catalyst drivers.

Brett

Offline iaresean

  • Cannon Fodder
  • **
  • Posts: 6
    • View Profile
Re: Trouble starting 2.2
« Reply #38 on: March 20, 2008, 10:56:04 pm »
:'(

I also have a Radeon X700 card.  Haven't been able to startup the game at all.

Have tried every trick/tip in this thread.  And have tried just about every driver out there.  I either get the 'no hardware detection' message, or the process simply dies after the startup process.

I was looking sooooo forward to this game, as xcom is one of my childhood memories.

Anyone manage to find a 100% solution for this yet?

Offline iaresean

  • Cannon Fodder
  • **
  • Posts: 6
    • View Profile
Re: Trouble starting 2.2
« Reply #39 on: March 21, 2008, 07:53:21 pm »
:'(

I also have a Radeon X700 card.  Haven't been able to startup the game at all.

Have tried every trick/tip in this thread.  And have tried just about every driver out there.  I either get the 'no hardware detection' message, or the process simply dies after the startup process.

I was looking sooooo forward to this game, as xcom is one of my childhood memories.

Anyone manage to find a 100% solution for this yet?

Sorry, I should have also mentioned my full specs:
Windows XP SP2 (32bit)
AMD Athlon 64 3000+
1g Ram
Radeon X700 256mb

I reeeeaaally wanna play this.  :-D

Offline BTAxis

  • Administrator
  • PHALANX Commander
  • *******
  • Posts: 2607
    • View Profile
Re: Trouble starting 2.2
« Reply #40 on: March 21, 2008, 09:01:33 pm »
You might have some luck with the 2.3 test installers (http://mattn.ninex.info/). Otherwise, I don't know.

Offline iaresean

  • Cannon Fodder
  • **
  • Posts: 6
    • View Profile
Re: Trouble starting 2.2
« Reply #41 on: March 25, 2008, 01:46:10 pm »
You might have some luck with the 2.3 test installers (http://mattn.ninex.info/). Otherwise, I don't know.

Sweet.  I am busy grabbing it now.  I will report back to you guys whether the new rendering engine has any effect on this issue.

Offline iaresean

  • Cannon Fodder
  • **
  • Posts: 6
    • View Profile
Re: Trouble starting 2.2
« Reply #42 on: March 26, 2008, 05:43:00 pm »
Sweeeeeeeeeeeeeeeeet!

The dev 2.3 version works 100%!

Nice!

Ok, now let me go try and play this bad boy.  :-D

Offline BTAxis

  • Administrator
  • PHALANX Commander
  • *******
  • Posts: 2607
    • View Profile
Re: Trouble starting 2.2
« Reply #43 on: March 27, 2008, 12:33:21 pm »
Just keep in mind that the 2.3 version is a development version. Stuff may work differently, or not properly at all (especially campaign related stuff).

Offline iaresean

  • Cannon Fodder
  • **
  • Posts: 6
    • View Profile
Re: Trouble starting 2.2
« Reply #44 on: March 27, 2008, 01:26:26 pm »
Hehe.

Yeah, thanks.  I picked up on that pretty fast.  Ran into a few 'dev' type situations.  :-D

Was dissappointed that I couldn't play it completely, but I was very excited by what I saw.  I will wait patiently for the official 2.3 release.

:-)