project-navigation
Personal tools

Author Topic: Can't Get 2.2 to run  (Read 6114 times)

Offline Doctor J

  • Squad Leader
  • ****
  • Posts: 265
    • View Profile
Can't Get 2.2 to run
« on: October 02, 2007, 09:44:47 pm »
I just installed 2.2 from the beta binary [This is Ubuntu Dapper Drake AMD64].  Installed *everything* in the package.  However, i still get no joy:

dave@ubuntu:~/ufoai$ ./ufoai
./ufo: error while loading shared libraries: libSDL_ttf-2.0.so.0: cannot open shared object file: No such file or directory


I do have the latest version of all the SDL libs:

dave@ubuntu:/usr/local/lib$ ls -l libSDL_ttf-2.0.so.0
lrwxrwxrwx 1 root root 23 2007-09-23 09:38 libSDL_ttf-2.0.so.0 -> libSDL_ttf-2.0.so.0.6.3


Offline Mattn

  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4831
  • https://github.com/mgerhardy/vengi
    • View Profile
    • Vengi Voxel Tools
Re: Can't Get 2.2 to run
« Reply #1 on: October 03, 2007, 10:01:33 am »
how did you install sdl_ttf? it should be in /usr/lib

did you install it via apt-get install libsdl-ttf2.0 ?

Offline Doctor J

  • Squad Leader
  • ****
  • Posts: 265
    • View Profile
Re: Can't Get 2.2 to run
« Reply #2 on: October 03, 2007, 08:13:28 pm »
how did you install sdl_ttf? it should be in /usr/lib

did you install it via apt-get install libsdl-ttf2.0 ?

Sadly, the libsdl stuff available through apt-get is only 1.2.9.  Instead, i got the 1.2.12 source from www.libsdl.org, then the usual configure/make/make install.  It looks like i will have to symlink the whole lot from /usr/local/lib to /usr/lib. :-\

Offline Mattn

  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4831
  • https://github.com/mgerhardy/vengi
    • View Profile
    • Vengi Voxel Tools
Re: Can't Get 2.2 to run
« Reply #3 on: October 03, 2007, 09:41:08 pm »
run configure with ./configure --prefix=/usr then make make install

Offline Doctor J

  • Squad Leader
  • ****
  • Posts: 265
    • View Profile
Re: Can't Get 2.2 to run
« Reply #4 on: October 05, 2007, 06:03:40 pm »
run configure with ./configure --prefix=/usr then make make install

Okeh, i deleted the SDL stuff in /usr/local/lib, then did as you said above.  Now when i try to run UFO:

dave@ubuntu:~/ufoai$ ./ufoai
./ufo: error while loading shared libraries: libSDL_ttf-2.0.so.0: cannot open shared object file: No such file or directory

dave@ubuntu:~/ufoai$ ls -l /usr/lib/libSDL_ttf*
lrwxrwxrwx 1 root root    23 2007-10-04 10:11 /usr/lib/libSDL_ttf-2.0.so.0 -> libSDL_ttf-2.0.so.0.6.3
-rwxr-xr-x 1 root root 74581 2007-10-04 10:11 /usr/lib/libSDL_ttf-2.0.so.0.6.3
-rw-r--r-- 1 root root 96368 2007-10-04 10:11 /usr/lib/libSDL_ttf.a
-rwxr-xr-x 1 root root   909 2007-10-04 10:11 /usr/lib/libSDL_ttf.la
lrwxrwxrwx 1 root root    23 2007-10-04 10:11 /usr/lib/libSDL_ttf.so -> libSDL_ttf-2.0.so.0.6.3


Now what should i do?

Punkiee

  • Guest
Re: Can't Get 2.2 to run
« Reply #5 on: October 06, 2007, 03:28:22 pm »
Are you sure that this is the lib you used when linking? That the dev headers are the same version as the lib? Are there any other versions of SDL_ttf on your system?
Maybe some ubuntu guru knows the cracks of the distro better.

Offline Doctor J

  • Squad Leader
  • ****
  • Posts: 265
    • View Profile
Re: Can't Get 2.2 to run
« Reply #6 on: October 06, 2007, 05:38:05 pm »
Are you sure that this is the lib you used when linking?

This is a precompiled binary provided by MattN