project-navigation
Personal tools

Author Topic: Sluggish FPS on WinXP  (Read 13578 times)

Alienshooter

  • Guest
Sluggish FPS on WinXP
« Reply #30 on: May 05, 2007, 02:35:00 am »
I downloaded 2.1.1, then switched my threaded otimization off in the NVIDEA control panel as mentioned (it had been set to auto), and voila! Works like a charm and is playable again.

I can't exactly remember, but It seems like this problem appeared when I upgraded to driver 100.65, and continued with the current driver 158.18 (I am using VISTA and have a Geforce 7950).

Skylinux

  • Guest
Sluggish FPS on WinXP
« Reply #31 on: May 15, 2007, 06:05:28 pm »
Quote

I have an 8800GTS and solved the problem by turning off the setting called
"Threaded optimization" in the nVidia control panel under "Manage 3D
Settings" page. I am currently using the 158.19 drivers. Changing the
affinity for the application did not help at all as has been noted in this
thread, but forcing the driver itself to use one core helped significantly.


I just wanted to add my comment, the game went from "playable" to being "addictive" with the change above. I had to play the mining mission before applying the above fix and the FPS where sooo low. Now I can equip my soldiers in half the time because the mouse moves without lag.
May I add the solution to the FAQ?

harsh

  • Guest
Sluggish FPS on WinXP
« Reply #32 on: May 16, 2007, 09:54:01 pm »
You've got my vote.  I didn't realize that there was a cetralized location for this sort of thing.

Skylinux

  • Guest
Sluggish FPS on WinXP
« Reply #33 on: May 25, 2007, 04:44:05 am »

wake?up

  • Guest
Sluggish FPS on WinXP
« Reply #34 on: May 27, 2007, 05:55:28 am »
Hi.
I got the same Problem.

First the game runs at 45 fps at very high settings at the "spedition6" map,
after i loaded the savegame, directly saved before the landing vraft reaches the mission place, the game runs at 4 fps, but only when one or
more of the soldiers are on screen.

My PC:
AMD X2 - 4200
GF 7800 GTX / 256MB
2GB RAM
Win XP Home SB
UFO AI @ 1024x768 resolution (1280x didnt work)

Its strange, cause first it runs without problems,
then with same settings, the game got anplyable.
Is me the only one with "first runnen / then dont" ?

mfg, wake

JPC28

  • Guest
Sluggish FPS on WinXP
« Reply #35 on: June 04, 2007, 01:22:03 am »
Im having the same problem with sluggish performance when in the equipment screen and in the 3d map whenever the units are visible plus choppy sound.  I am using an old nvidia 6600 and my system is dual core. I can't find the option to turn off threaded optimization in the nvidia manage 3d settings.  :cry:

JPC28

  • Guest
Sluggish FPS on WinXP
« Reply #36 on: June 04, 2007, 01:50:48 pm »
Problem solved! Switching to just 1 cpu solved the problem, game runs smoothly now. Must be a problem with dual core cpu's.

Windows Task Manager >Processes > right click UFO.exe click on set affinity and uncheck one of the cpu's. the game should run fine now :)

Offline Berserker

  • Cannon Fodder
  • **
  • Posts: 2
    • View Profile
Sluggish FPS on WinXP
« Reply #37 on: August 14, 2007, 01:25:55 pm »
Quote from: "JPC28"
Problem solved! Switching to just 1 cpu solved the problem, game runs smoothly now. Must be a problem with dual core cpu's.

Windows Task Manager >Processes > right click UFO.exe click on set affinity and uncheck one of the cpu's. the game should run fine now :)

For automatic select CPU core, use this code:
SetThreadAffinityMask(GetCurrentThread(), mask);
For example:
mask=1 - use core #0
mask=2 - use core #1
mask=3 - use cores #0 and #1
For default I recomended :
SetThreadAffinityMask(GetCurrentThread(), 1);

More simple way to solve this problem:
SetPriorityClass (GetCurrentProcess(), HIGH_PRIORITY_CLASS);
or
SetPriorityClass (GetCurrentProcess(), REALTIME_PRIORITY_CLASS);

Regards
Berserker

Offline Destructavator

  • Combination Multiple Specialty Developer
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 1908
  • Creater of Scorchcrafter, knows the zarakites...
    • View Profile
Sluggish FPS on WinXP
« Reply #38 on: August 15, 2007, 01:11:35 am »
Just so people know, I have a dual-core desktop that runs this game just fine in Windows MCE without any special tweaks, at 1280x1024, but I have Intel Core CPUs in a Dell XPS, not AMD.

It bombs out with errors if I try to run it under Vista though, although in Vista I didn't try any tweaking yet.  (My desktop triple-boots.)

As a side note, I'm currently working on reloading the new Kubuntu Gustsy Beta (Debian-based Linux) on my laptop, and it has intel-based video hardware (I think the front page mentioned this), and I'm curious to see if the game runs under that environment.

EDIT: Forgot to mention, my desktop has an Nvidia video card.

Offline Berserker

  • Cannon Fodder
  • **
  • Posts: 2
    • View Profile
Sluggish FPS on WinXP
« Reply #39 on: August 15, 2007, 04:48:09 am »
I'm not test Vista, may be this OS have not this bug.
I have Windows XP SP2 + standart tweaks for dual core CPU

Tommy

  • Guest
Re: Sluggish FPS on WinXP
« Reply #40 on: May 01, 2008, 12:36:56 pm »
I got same problem.
I cant change resolution to 1280x1024 (LCD Panle) I tryed to change manualy in config but nothing changed.
I change resolution in game but nothing hapends. After restart it`s still at 1024x768.
Framerate ~50-60fps normal ?

I got Windows Vista x64 on single core AMD Athlon64 4000+ (4GB RAM) with nVidia GF-7800GT