project-navigation
Personal tools

Author Topic: Sluggish FPS on WinXP  (Read 13561 times)

zodde

  • Guest
Sluggish FPS on WinXP
« Reply #15 on: April 29, 2007, 05:11:11 pm »
Hi all!.

I can confirm this bug. And it seams to be related to newer systems using Dual Core or PCI Express cards. Or newer Nvidia Cards.

Old system without any problems

P4 478 2.8Ghz
Geforce 6600 GT 128 MB AGP
1 Gig memory
XP SP1

New system with lag in equip mode and in tactical maps when I can se many of my soldiers.

Dual Core E6400 2.12 Ghz
Geforce 7600 GT 256 MB PCI Express
2 Gig memory
XP SP2

So one or more of the above seams to cause this lag. In equip window i had somewhat lag in all "modes" (Master, Secondary etc etc except for Armor and it was empty of things).

This makes the game unplayable for me right now and this issue needs to be adressed ASP. No point releaeing the 2.1.1 until this is fixed in my opinion.

Otherwise, the little I played the game on the old system (just about 5-6 times before the CPU burned!) shows me that this is a great game! Now only this bug has to be found and solved.

Regards
Zodde

Cougar_DK

  • Guest
Sluggish FPS on WinXP
« Reply #16 on: May 01, 2007, 05:28:42 pm »
I have just installed version 2.1.1 win 32 and I still have this problem.  My pc is an AMD XP 64 4400 and Nvidia 8800 GTS 640 OC2. Running XP Pro DK.

(Got new graphic card, since my last post)

zodde

  • Guest
Sluggish FPS on WinXP
« Reply #17 on: May 02, 2007, 10:41:10 am »
I have seen no response from the Dev Team regarding this issue lately, has this problem been recognized or not?

Right now is the game unplayable for me, and as it seams to be a bunch of other users that have the same problem.

Offline Zenerka

  • Sergeant
  • *****
  • Posts: 301
    • View Profile
Sluggish FPS on WinXP
« Reply #18 on: May 02, 2007, 01:27:10 pm »
The problem is not recognized, because... it is not reproduceable here - on Windows XP. I have no clue what to advise/what to do in this case. :(

Offline Zenerka

  • Sergeant
  • *****
  • Posts: 301
    • View Profile
Sluggish FPS on WinXP
« Reply #19 on: May 02, 2007, 01:51:02 pm »
Maybe just one tip, which had helped some other people with Windows and "slow FPS" problem, to quote:
"I actually found the solution to that problem of FPS. In my NVIDIA Control Panel, the visual settings were forced. I just had to "let the 3D application decide" of the settings. Then OpenGL is activated by UFO:AI. Thanks for having led me in the good direction!"

Offline Mattn

  • CaveExpress
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4830
  • www.caveproductions.org
    • View Profile
    • CaveExpress
Sluggish FPS on WinXP
« Reply #20 on: May 02, 2007, 05:40:54 pm »
a reply by Greg Winters:
Quote

I have an 8800GTS and solved the problem by turning off the setting called
"Threaded optimization" in the nVidia control panel under "Manage 3D
Settings" page.  I am currently using the 158.19 drivers.  Changing the
affinity for the application did not help at all as has been noted in this
thread, but forcing the driver itself to use one core helped significantly.

zodde

  • Guest
Sluggish FPS on WinXP
« Reply #21 on: May 02, 2007, 06:43:07 pm »
Hi again!

The suggestion with turning off Threaded optimization" solved the problem. Now Im back to 45fps in tactical mode.

If this is something that cant be addressed by UFO AI team I suggest this is to be inserted in the manual. I would guess all the newer Nvidia Cards will have this problem since it have been reported from atleast 7600 GT and 8600 GT  cards...

With regards

Cougar_DK

  • Guest
Sluggish FPS on WinXP
« Reply #22 on: May 02, 2007, 08:11:24 pm »
And it worked for me too. Great!  :D

Offline Mattn

  • CaveExpress
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4830
  • www.caveproductions.org
    • View Profile
    • CaveExpress
Sluggish FPS on WinXP
« Reply #23 on: May 03, 2007, 11:13:19 am »
to help us to track this issue down, could you please try to activate this feature again, start ufo, open the gameconsole, type
Code: [Select]
gl_finish 1
exit ufo and start again.

if this doesn't help, you have to set gl_finish to 0 with your next ufo start

thanks

zodde

  • Guest
Sluggish FPS on WinXP
« Reply #24 on: May 03, 2007, 08:46:44 pm »
Hi.

I tried the gl_finish 1.

I saw no effect. With the multi threading option turned on, the Fps was around 5-10 fps in combat and equipmode.

Im happy to try out other settings if requested!

Just a note for comparison. I tried 3dbechmark05. With this setting turned off i got 6600. With it turned on I got 6000 about. So it might just be some crappy drivers from Nvidia aswell.

harsh

  • Guest
Sluggish FPS on WinXP
« Reply #25 on: May 03, 2007, 09:35:23 pm »
This does seem like a driver issue, since this setting affects something outside of the control of the application.  Oddly, Quake3 seems to run just fine, but I don't know if it is because of the stupid nVidia CP switching settings for it.

I haven't really noticed a performance change in other games with the threading opt. disabled, but I haven't been paying attention.

Reenen

  • Guest
Sluggish FPS on WinXP
« Reply #26 on: May 04, 2007, 09:24:18 am »
Hi,

What is the system requirements for the game?

It works at my work, but it is sluggish on the Global map (10fps), which to me is really slow.  The Tactical map is slow as well (17fps).

This is after I went down resolution to 640x480.

I have:
Operating System: Windows XP Professional (5.1, Build 2600) Service Pack 2 (2600.xpsp_sp2_gdr.061219-0316)
Language: English (Regional Setting: English)
System Manufacturer: MICRO-STAR INTERNATIONAL CO., LTD
System Model: MS-7235
BIOS: Phoenix - AwardBIOS v6.00PG
Processor: Intel(R) Core(TM)2 CPU          6400  @ 2.13GHz (2 CPUs)
Memory: 1022MB RAM
Page File: 599MB used, 1860MB available
Windows Dir: C:\WINDOWS
DirectX Version: DirectX 9.0c (4.09.0000.0904)
DX Setup Parameters: Not found
DxDiag Version: 5.03.2600.2180 32bit Unicode


Card name: RADEON X300/X550 Series
Display Memory: 256.0 MB


At home, the game doesn't start up.  I don't have the specs here, but it sucks. :-)

Here's my guess though:
P4 2.4 or so, on board graphics, and 256mb ram.

Offline Mattn

  • CaveExpress
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4830
  • www.caveproductions.org
    • View Profile
    • CaveExpress
Sluggish FPS on WinXP
« Reply #27 on: May 04, 2007, 09:47:08 am »
try to switch to single core - right click ufo.exe in taskmanager to set this

Reenen

  • Guest
Sluggish FPS on WinXP
« Reply #28 on: May 04, 2007, 01:42:49 pm »
Nah... that didn't improve the FPS.

The FPS in geoscape is what really bothers me.  The tactical seems fine.

zodde

  • Guest
Sluggish FPS on WinXP
« Reply #29 on: May 04, 2007, 10:35:51 pm »
Ok I tried that. I turned back on the Threaded Optimization and started the game, entered the equip mode and the FPS crashed down to 7 fps. Went back to desktop and changed the no of CPU:s the game could use down to one.

The game went straight back up to 45 Fps again. I then tried to turn back on so it could use two CPU:s but the FPS stayed at 45.

So it seams that there is some kind of problem that could be handled from the UFO AI code? Are you guys using threads?

More things you want me to test out? Glad I can help!