project-navigation
Personal tools

Author Topic: Can't load Savegame  (Read 13899 times)

Phantom

  • Guest
Can't load Savegame
« Reply #30 on: April 10, 2007, 11:43:51 pm »
In the reasearch screen I did not open the info on research item, in other words I did not click the mail icon. Thats what I ment...

Offline Mattn

  • CaveExpress
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4830
  • www.caveproductions.org
    • View Profile
    • CaveExpress
Can't load Savegame
« Reply #31 on: April 11, 2007, 07:53:23 am »
what languages are you all using? i mean all those whos savegames are broken? are you using english or other languages?

Kris

  • Guest
Can't load Savegame
« Reply #32 on: April 11, 2007, 08:49:47 am »
Quote from: "Mattn"
what languages are you all using? i mean all those whos savegames are broken? are you using english or other languages?


I'm using Polish, but I'll change it to English and see what happens...

I'll try, 3rd time, play from the beginning, this time, in English.

PS. But, after lang. change, old saved games not load...

playmobil

  • Guest
Can't load Savegame
« Reply #33 on: April 11, 2007, 09:51:46 am »
I'm using the french version.

kafka

  • Guest
Can't load Savegame
« Reply #34 on: April 11, 2007, 11:50:26 am »
I' m using the german version

Phantom

  • Guest
Can't load Savegame
« Reply #35 on: April 11, 2007, 11:56:39 am »
As far as I can tell I am using the english/USA/internatinal version, I did not change it from default...
How ever on start up in log (first view lines of a 5.3 Mb log file):
Quote
Winsock Initialized
Hostname: xxxxxxx
IP: xxx.xxx.xxx.xxx
...could not set to language:
...could not set to system language
Console initialized.


I got a systems crash "Assertion failed" that is reported in another forum entry. I was requested to make this larger log file, hence the size of it :lol:
Notepad realy has a problem with these sizes :lol:

Hope it helps dough... ;)

ps.: Blanked out IP and Machine name, for obvious reasons :lol:

Offline blondandy

  • Sergeant
  • *****
  • Posts: 391
    • View Profile
Can't load Savegame
« Reply #36 on: April 11, 2007, 12:11:27 pm »
I have got the broken savegames playing in english, not changing from default. (though I havent checked if I have the "could not set to language" startup log entry.

A reply for the Dutch Phantom on page 2:
Serialization (in this context) is saving the state of the game (ie your progress, in a more sensible way than a memory dump).
see http://en.wikipedia.org/wiki/Serialization

I would suggest that if you don't know how to code in c, you will not be able to help. (You could always try and learn).

I would like to help too and am just starting to learn about SVN, and revise c.

Phantom

  • Guest
Can't load Savegame
« Reply #37 on: April 11, 2007, 12:19:28 pm »
Thanks for the link !

After reading all of that, I come to one conclusion: am to stupid to help :cry:

Offline Zenerka

  • Sergeant
  • *****
  • Posts: 301
    • View Profile
Can't load Savegame
« Reply #38 on: April 11, 2007, 12:25:52 pm »
Phantom, let me get this straight. You had problems with saved games when you clicked in the mailclient icon on the geoscape, and you had no problems with saved games when you did not clicked that mailclient icon?

Kris

  • Guest
Can't load Savegame
« Reply #39 on: April 11, 2007, 12:30:52 pm »
Maybe this will help:

http://www.codeproject.com/cpp/xmlserialization.asp

Is there any possilbility to get a sample save/load source code and customize it?

PS. I've never program with C.

kafka

  • Guest
Can't load Savegame
« Reply #40 on: April 11, 2007, 06:47:45 pm »
yes, xml serialization is easy and effective, I use it myself in my own projects though I do not program in c++ anymore but in c# and java. C and c++ are compared to c# and java nasty languages, particularly the missing automatic memory management is a real plague. I would like to help but not in c / c++.

Phantom

  • Guest
Can't load Savegame
« Reply #41 on: April 11, 2007, 11:29:18 pm »
I as a USER look for ways to simplefy the search for errors.
One way is to click as view times as you can to change stuff, save & load and then report the failure if you get any. After that its up to the real programers to figure it. ;)

And YES I did all the game lets me at this point:
- Did wars, land and air...
- Did buy / sell equipment...
- Did build, even hospitals (4 of them)...
- Did hire and fire people...
- Did Build 4 bases and renamed them...
- Did research all the research available:
  - All plasma
  - All laser
  - All particle (cant use the rifle as ammo is not researched it says)
  - 3 Aliensraces
  - Aliens and alien breathing aparatus
  - Got no research left it says (for now) ;)
- Did catpure and study one race...

All these steps i did a SAVE and in the same go a LOAD to test the savegame I just saved.
At this point I was in the 46th save game with out any problems at all !
As the info screen (click on email icon lower right) in research gives me sometimes weird filenames and or weird picture blobs I avoided opening the info screen.
After openening the mentioned infoscreen, forced because of the particle rifle not working with out ammo, my game started having these save games errors again: Load and pup right in to the main menu...

Reading through the log file:
- I had errors on language at start up...
- I had errors with skill >100 (reported in wars)...
- I had errors on missing music on some war maps...
- I had some messages about map items beying missing...
- I had messages of buttons allready existing...

After a restart of an urlier save game all went ok until I got a more serious problem witch is posted in another forum entry, namly an ASSERTION FAILURE, what ever that is :lol:
But thats at save nr 50 something...

Thats all I can say as a game player ! I dont program C/C++ !

What I dont understand:
- Why are the particle rifles I have in stock one group light brown and another group dark brown ? But thats another forum entry question ;) :lol:

Switch

  • Guest
Can't load Savegame
« Reply #42 on: April 13, 2007, 09:58:58 am »
Same problem here, running Ufo:AI 2.1 compiled from source under Gentoo with locale fr_FR.UTF-8.

This was my first install, I run the game, finish the first mission, saved, and when I came back to load, I was return to the menu and this in the console :
Code: [Select]
CL_CampaignActivateStage: stage '.
                                  ' not found.
Unable to load campaign 'slot1', unknown stage '.
                                                 '


This is not shown here but there is a ^K just after the point in the ' ' if I open the log in vim.

I used a named starting with a maj, and as i saw here that majs could broke the saves, I tried whitout, that seems to work, at least for a time because now after like 8 or 9 missions, and around the same amount of saves, the loading of the last save failed, with exactly the same problem (and the ^K).

I have built a new base, and an hospital (but at least 2/3 save before the bug appear) and i have accomplish some research.

But viewing all the report here and beeing a software engineer, my guess would be that it's not really related with what you have done or not. What really catch my attention is the fact that it's always a ^K that appear (which i guess correspond to the unicode someone told a few post before).

Anyway, as you, I think that a serialized save would be really better, and xml ones the best.

Offline smalul

  • Rookie
  • ***
  • Posts: 35
    • View Profile
Can't load Savegame
« Reply #43 on: April 20, 2007, 01:53:26 pm »
I have the same problem - I can't load any of my saved games (which is very bad, because I played a lot, researched everything I could, and reached the "aliens are invading" stage). My ufoconsole.log shows a similar error when trying to load a saved game:
Code: [Select]
====== UFO Initialized ======

Savefile version 6 detected
Global data loaded - size (null)u bytes
...techs: 134
...buildings: 18
...ranks: 8
...nations: 8

CL_CampaignActivateStage: stage 'n' not found.
Unable to load campaign 'slot6', unknown stage 'n'
Changing to Singleplayer
Savefile version 6 detected
Global data loaded - size (null)u bytes
...techs: 134
...buildings: 18
...ranks: 8
...nations: 8

CL_CampaignActivateStage: stage 'n' not found.
Unable to load campaign 'slot5', unknown stage 'n'
Changing to Singleplayer
Savefile version 6 detected
Global data loaded - size (null)u bytes
...techs: 134
...buildings: 18
...ranks: 8
...nations: 8

CL_CampaignActivateStage: stage 'n' not found.
Unable to load campaign 'slot4', unknown stage 'n'
Changing to Singleplayer
Savefile version 6 detected
Global data loaded - size (null)u bytes
...techs: 134
...buildings: 18
...ranks: 8
...nations: 8


Now, the reason I'm adding my comment here is because someone wrote something about hospitals and this loading bug. Well, in my case, I saw that in a hospital (actually, it's a double hospital) in one of my 3 bases, the stats showed there was 1 soldier healing, but there were no soldiers listed. So I've decided to save, and reload the game to check if that problem is still there, and then I found out ALL my saved won't load. I'm guessing this save bug didn't crash the game, but kept getting saved, and as I played for about 2 hours, and saved before and after every mission, the bug "infected" all my saved games, so I lost them all.

Also - would there be a fix that would allow me to load those "broken" saved games, or am I way too optimistic?

Offline Zenerka

  • Sergeant
  • *****
  • Posts: 301
    • View Profile
Can't load Savegame
« Reply #44 on: April 20, 2007, 01:59:29 pm »
You are too optimistic, I am afraid. :( We weren't able to find out the real source of savegame bug.
That's why mattn worked hard last week on completely new savegame system. Now I can say it looks like finished, and I hope today we will publish here links to new testinstallers for 2.1.1 with a request of heavy testing. The old saved games won't work here, of course.