project-navigation
Personal tools

Author Topic: Can't load Savegame  (Read 13879 times)

WhiteAngel

  • Guest
Can't load Savegame
« Reply #15 on: April 07, 2007, 11:06:25 pm »
I have the same problem. I'm unable to load a saved game somewhere in July 2084 in Standard campaign. The error was the same as above (unable to load stage something). I built the hospital, yes. I didn't researched any plasma weapons yet. The nanocomposite armor was already researched.

Is there any debug mode I could switch on to be more verbose in console about the error?

System is Ubuntu Linux Edgy 6.10 having the official binary version 2.1.

WhiteAngel

  • Guest
Can't load Savegame
« Reply #16 on: April 07, 2007, 11:19:54 pm »

Offline blondandy

  • Sergeant
  • *****
  • Posts: 391
    • View Profile
Can't load Savegame
« Reply #17 on: April 08, 2007, 12:08:32 am »
It is the same bug. I played the game through a couple of times now, and it always getd to a point were the save game will not load. I started cycling through save slots. I have examples of the last savegame to work and the first broken savegame. I will upload them to the sourceforge bug tracker. hopefully they can help you work it out.

Offline blondandy

  • Sergeant
  • *****
  • Posts: 391
    • View Profile
Can't load Savegame
« Reply #18 on: April 08, 2007, 12:22:41 am »
here is some text from the corresponding ufoconsole.log. slot1 is broken, but slot7, from 2 days earlier (game time) works. If this isnt enough info, see the actual savegames (uploaded to sourceforge bug tracker).

CL_CampaignActivateStage: stage 'ed_and_landed' not found.
Unable to load campaign 'slot1', unknown stage 'ed_and_landed'
Changing to Singleplayer
Savefile version 6 detected
Global data loaded - size (null)u bytes
...techs: 134
...buildings: 18
...ranks: 8
...nations: 8

Activate stage ufos_are_coming
Campaign 'slot7' loaded.
Initializing aircraft and aircraft-items ...
...aircraft and aircraft-items inited
Changing to Singleplayer

Phantom

  • Guest
Can't load Savegame
« Reply #19 on: April 08, 2007, 12:39:16 am »
Idem on all except:
XP SP1 = XP SP2 on my end...
The message in the logg file (With notepad opened):
Quote
==== ShutdownGame ====
Savefile version 6 detected
Global data loaded - size (null)u bytes
...techs: 134
...buildings: 18
...ranks: 8
...nations: 8

CL_CampaignActivateStage: stage '.. ' not found.
Unable to load campaign 'slot3', unknown stage '.. '
Changing to Singleplayer


Also I had a weird message on the research info screen on some item and taken no notice of it as it is still a game in progress ;)
I got a single line in sted of a big info it said "blablabla.txt" or something like that...

Also saving the game in empty slots gave me some errors after playing for a while to, as reported in another forum entry. Alldough running on a 2 Gig memory with 32 Gig HD free, still reported it had not enough memory to save on the HD. Leaking somewhere ? Maybe this error screws also the save games up ?
After all slots where full with save games, it stopped not saving them...

I hope all this toghether with other replies helps you fix this old memory lane game. Loved it then to play, love it now. Love it so mutch I restarted playing just for fun, but not saving and not shutting down my pc :lol: But i think there is something seriously wrong and my existing save games wil not work in version 2.1.1, I am afraid ! :shock:

Keep up the good work ! :lol:

Phantom

  • Guest
Can't load Savegame
« Reply #20 on: April 08, 2007, 01:03:40 am »
For what its wurth I looked in the save file 3:
Neither Notepad and Write can find the string reported as unknown '.. ' .
So looked for the .. only in both programs and found it 3 times. All is jibrish in the save files anyway, but no '.. '  at all ??

Hope that helps...

astropanic

  • Guest
Can't load Savegame
« Reply #21 on: April 08, 2007, 10:50:21 am »
I tried loading a game but it just goes back to the loading screen, same error as the previous user.  I do not know how to fix it and I have very little knowledge and experience on code, so if someone does know the solution, can you give me a step by step process on how to fix this?  I'm really far into the game, I don't even have anything else to research.

tchou

  • Guest
Can't load Savegame
« Reply #22 on: April 08, 2007, 07:19:57 pm »
I have the same problem, plus another one (?) also related to the savegames : some savegames are failing to load, and others also, but they crash the game. (win 2000)

A save that don't load is :
Quote
CL_CampaignActivateStage: stage '. ' not found.
Unable to load campaign 'slot1', unknown stage '. '
Changing to Singleplayer
Savefile version 6 detected
Global data loaded - size (null)u bytes
...techs: 134
...buildings: 18
...ranks: 8
...nations: 8


And a save that crash the game :

Quote
CL_CampaignActivateStage: stage '. ' not found.
Unable to load campaign 'slot1', unknown stage '. '
Changing to Singleplayer
Savefile version 6 detected
Global data loaded - size (null)u bytes
...techs: 134
...buildings: 18
...ranks: 8
...nations: 8

Warning: Mission '. ' not found


The last corrupted (first one, the one that don't crash the game) save was at the end of a mission where i captured an alien, enabling the research. And at the same time, there was an announce that UFO were in the atmosphere.

Offline PounincgAnt

  • Cannon Fodder
  • **
  • Posts: 1
    • View Profile
Can't load Savegame
« Reply #23 on: April 09, 2007, 07:13:21 pm »
Hey, I'm also suffering from this bug. Is this bug common enough that us victims will be seeing a bugfix release soon?

This latest release looks excellent, Its such a shame I cant test it properly!

PhaD

  • Guest
Can't load Savegame
« Reply #24 on: April 09, 2007, 08:47:41 pm »
I've got the same problem, the game crashed after i try to load a Savegame - and indeed, i had a hospital in my 1st base ...  all other savegames without a hospital do not crash!

kafka

  • Guest
Can't load Savegame
« Reply #25 on: April 09, 2007, 10:15:33 pm »
hi,

well, I haven't built any hospitals but cannot load my save game too

Phantom

  • Guest
Can't load Savegame
« Reply #26 on: April 10, 2007, 01:47:18 pm »
I got 4 bases now all with hospitals and the works, am at the 45rd save and I can say it is still running smoothly ! :lol:
I researched all the weapons available: Laser, Plasma, Particle. Aliens are all researched to. Researching breathing aparatus now. What I didnt do this time: OPEN UP THE RESEARCH INFO SCREEN or ALT TAB TO WINDOWS !
I changed all bases names like: Central Africa, USofA, etc...
Still the game runs very good and smooth ! :lol:

As a hobby programer I look for weird things in game, that may occure and render parts of the memory usless, that we cant see untill its needed by the game and makes it crash or do weird stuff. I think the savegame failure is some memory leak that makes savegames useless, but heck I am hobby programer (not even shure thats the wright name for my skills)  not a pro like you guys ! :roll:

Some bugs as reported by the game itself:
- Some of my soldiers have 101 of assault weapon skill, the game reports it in the game screen as a white text... I DID NOT HACK THE SAVE FILE !
- The further I come in the game, the more stuff is missing, like music and some "weapon ammo" (reported in console and in war screen as white text). Also this can create memory leaks if buffers are created for stuff that return errors. Maybe the buffers are not deleted or deleted with no buffer present ? ( :> Not enough memory to save the file <: )

Some stuff i find tricky to memory usage as it is on my end:
- Some pictures, in the research info screens, come in with some weird blob middle right of the screen. Sometimes it happens in war screen to.
I just hope its a blob and not some picture I cant uderstand the use of :lol:
- Entering a text, be it new base name or save game, it needs several SHIFT+Alpha key presses to make the caps letter accepted by the game.
Also reported error as missing missions and mission names, reports weird characters that are not even in the save file itself (checked with value checker not notepad this time)... But if the log file reports the correct value as a weird UNIcode char I dont know.
This makes me guess there is an ANSI <-> UNICode translation error that occures sometimes on the background :roll: May be wurth looking in to ;)

I hope this helps you track this nasty little alien bug and kill it so we all can continue this very good piece of work and kill the big alien bugs ! :lol:
But so far I am cool as it works fine :lol:

Offline Mattn

  • CaveExpress
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4830
  • www.caveproductions.org
    • View Profile
    • CaveExpress
Can't load Savegame
« Reply #27 on: April 10, 2007, 02:09:25 pm »
we need a real serializer for our savegames - but currently this is only a memory dump.

a serializer would also help to make savefiles exchangeable and let them work with newer versions, too

if someone wants to contribute... this is a good starting point ;-)

Phantom

  • Guest
Can't load Savegame
« Reply #28 on: April 10, 2007, 05:03:27 pm »
I am dutch and dont understand, stil I seem to grasp you need more input ?

What is serialising ?
What do you need from us ?

I'll help all I can to locate or contribute locating this bug !
First a view questions of my own:
- Can we back up our save games, like save 8 files, rename and do another 8 save file ?
- Where do we send our save files to, I dont have web space ?
Asuming thats what you need and mean with serialize...

Console dump ? I am lost :lol:

Offline Zenerka

  • Sergeant
  • *****
  • Posts: 301
    • View Profile
Can't load Savegame
« Reply #29 on: April 10, 2007, 10:26:11 pm »
Quote from: "Phantom"
IWhat I didnt do this time: OPEN UP THE RESEARCH INFO SCREEN or ALT TAB TO WINDOWS !

What research info screen? You mean mail client (mail icon on geoscape) or ufopedia?