project-navigation
Personal tools

Author Topic: Windows Vista  (Read 5264 times)

brpemerson

  • Guest
Windows Vista
« Reply #15 on: March 18, 2007, 08:13:51 pm »
Not work yet...

The install is perfect, but when I try run the game, the display stay black, later the display back to the desktop, and nothing... I see in task manager and the process not listed.
No errors appear...

Thank you...

Emerson

Offline Mattn

  • CaveExpress
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4830
  • www.caveproductions.org
    • View Profile
    • CaveExpress
Windows Vista
« Reply #16 on: March 19, 2007, 07:07:42 am »

brpemerson

  • Guest
Windows Vista
« Reply #17 on: March 19, 2007, 10:29:59 am »
I download this version... and not work....

Emerson

Offline Mattn

  • CaveExpress
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4830
  • www.caveproductions.org
    • View Profile
    • CaveExpress
Windows Vista
« Reply #18 on: March 19, 2007, 10:37:21 am »
please try to start with the parameters +set vid_fullscreen 0 +set snd_init 0

brpemerson

  • Guest
Windows Vista
« Reply #19 on: March 19, 2007, 09:24:36 pm »
Not work too...
 :(

Offline Mattn

  • CaveExpress
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4830
  • www.caveproductions.org
    • View Profile
    • CaveExpress
Windows Vista
« Reply #20 on: March 20, 2007, 07:42:06 am »
please try to extract the base/*zip files

in a way that you have:
base/maps
base/music
base/textures
base/sounds
[....]

and retry please

please also have a look at the ufoconsole.log which should be in your home dir (application data) in ufoai/.ufoai/base

thanks

chungng

  • Guest
Windows Vista
« Reply #21 on: March 20, 2007, 04:29:14 pm »
I tried some of the stuff you suggested, but no dice.  Here's the snippet of the log that seemed most useful:

...could not set to language:
...could not set to system language
Console initialized.
couldn't load history
------- Loading ref_gl.dll -------
ref_gl version: GL 0.12
Initializing OpenGL display
...setting mode 6: 1024 768 FS
...attempting fullscreen
...using desktop frequency: 50 hz
...using desktop display depth of 32
...calling CDS: ok
GLimp_Init() - no hardware acceleration detected
VID_CreateWindow() - GLimp_InitGL failed
ref_gl::R_SetMode() - invalid mode
Initializing OpenGL display
...setting mode 3: 640 480 W
ref_gl::R_Shutdown() - wglMakeCurrent failed
...setting windowed mode
GLimp_Init() - no hardware acceleration detected
VID_CreateWindow() - GLimp_InitGL failed
ref_gl::R_SetMode() - could not revert to safe mode
ref_gl::R_Init() - could not R_SetMode()

Seems like OpenGL isn't working very well.  I'm running on a thinkpad T43P, so the FireGL v3100 card in it should be able to do OpenGL just fine.  Could it be that the Vista drivers don't have OpenGL support just yet?

chungng

  • Guest
Windows Vista
« Reply #22 on: March 20, 2007, 04:56:29 pm »
I went to ATI and installed the Radeon Mobility X300 drivers (they didn't have any FireGL drivers for some reason, so I used the enthusiast equivalent), and the game works now.

brpemerson

  • Guest
Windows Vista
« Reply #23 on: March 20, 2007, 11:07:23 pm »
WORKS!!!!!!!!!!!!!!!

But now, I'm not sure what make the game work, because I extract the *.zip files and update the ATI drivers...
But now, works perfectly...

Thanks a lot,
best regards...

chungng

  • Guest
Windows Vista
« Reply #24 on: March 21, 2007, 07:45:28 pm »
I tried unzipping the files before, but doing that alone did not work.  Not sure if only replacing the driver will fix things.  If not, then there could be a bug in the installer.  Ah well, it's still a dev build, so I'm not overly concerned as long as I can get it to work!

neomunk

  • Guest
Windows Vista
« Reply #25 on: March 23, 2007, 12:44:09 am »
Hi there.  I've been running ufo:ai on vista too, but I've been running RC6, not the latest beta.  I don't remember any specific install issues, but I've installed quite a bit of software and lots of issues have come up.  If there was something amiss, I fixed it without a big hassle.

I'm going to grab up the latest beta and try it out for a bit.  I've been experiencing lock ups of my video driver (but vista resets it w/o crashing) but that probably has more to do with this laptop's video arrangement.  Anyways, I think this game is a great piece of work.  Improving on a really excellent game is hard to do, but it's obvious you'll have succeeded as soon as you're 'finished' (the quotes are there cause I know how these open source things go, you're never fully finished until it has every appropriate feature imagined).

So thanks, and though I'm not a strong programmer, I'll do what I can to chip in.