project-navigation
Personal tools

Author Topic: Some fuzzy bugs, appearing simulteneously in current 2.6  (Read 444 times)

Offline nick87720z

  • Rookie
  • ***
  • Posts: 38
    • View Profile
Some fuzzy bugs, appearing simulteneously in current 2.6
« on: February 07, 2019, 08:57:42 pm »
I'm playing 2.6, from commit f8a652df9221007449fed3b21c66b28de5a314dd:
* Make it possible to utilize the whole screen on "fill"-ed windows (set proper window size)

During game runing session three bugs begin to appear (nearly at the same time, listing in order i usually notice them during gameplay):
- Movement time indicator doesn't appear when i'm to move soldier.
- For some (but not all) soldiers it is impossible to fire weapons: if i choose fire mode from menu, cursors changes from crosshair with movement position marker to simple green crosshair, but not aiming one. For some soldiers, however, it still works. E.g., i fired with two soldiers than switched to next. Bugs happens with most soldiers, excepting previous two (may be more, but most - exactly).
- Soldiers health bar disappears - i faced it both at geoscape during base management and during mission.

For first i found similar bug:
https://ufoai.org/bugs/ufoalieninvasion/issues/5389

Other two - i don't know what search phrase is suitable, probably it is not reported.
"cannot fire" search on bugtracker gave something seemingly unrelated.

Since first bug could not reproduced by anyone - i don't know, what exactly leads, so i will describe my sequence.
I began new standard game.
- Founded base at africa, added new one lab, factory, interceptor hangar to base.
- Built ufo storage and two radars in south america.
- Dearmed soldiers, pulled out, repulled back 12 soldiers, watching to stats.
- Bought aircraft and soldier gear, selling unused (autopistols, rocket launchers, TR-20, etc).
- Loaded dropship crew with full weight for better training - so base inventory has dozens of GL frag ammo (i made set of versatile groups, each with AR, close combat, sniper and bombers/GL).

Accelerated time until March 26, at then got first scout on base radar (at africa). It landed in close asia city before fighters could reach it - when i got africa happiness lowered just before, i sent stiletto for some patrol to look to edge pieces, uncovered by radar, and it was too far to make it in time.
Bugs appeared during tactical mission. With my full-encumbered soldiers i managed to kill one taman and corner another and spider, tamans are with blades (i prefer snapshots for training, using bursts only in critical situations, as well as pistols intead of shotgun due to better accuracy by default).

I don't know, when healthbar disappeared from stats (i don't monitor it specially during play - it is just crazy, i even forgot about this bug, as it did not happen while i played post-endgame just before this new attempt). So, the only warning that can't be missed is inability to activate firing cursor mode for most soldiers.

Game restart fixes all bugs.
When i played endgame and later at previous attempt, game simply began to slowdown gradually, making some operations torture, e.g. selling/buying or adding items to be sent. But i remember it appearing in begining - can't remember, when this sort of bugs disappeared.

Edit: forgot another symptom - in geoscape time control keys stop working (don't remember what if just click these buttons).
« Last Edit: February 09, 2019, 04:46:19 am by nick87720z »

Offline Gu-Doc

  • Cannon Fodder
  • **
  • Posts: 5
    • View Profile
Re: Some fuzzy bugs, appearing simulteneously in current 2.6
« Reply #1 on: February 09, 2019, 01:59:26 pm »
to nick87720z
I have the same problems ,when I throw smoke grenades into certain areas :
1) exit from hercules AirCraft (jungle map with crocodile loadscreen)
2) entrance to the Hunter UfoCraft (Snow map)
3)when a grenade falls through textures /map borders
4)when I throw 3-4 smoke/incendiary grenades into one place
5)sometimes it happens when i use  googles +smoke in snow maps

in this case there are no sound and visual effects , but there are problems you write about.

Offline DarkRain

  • Project Coder
  • Captain
  • ***
  • Posts: 746
    • View Profile
Re: Some fuzzy bugs, appearing simulteneously in current 2.6
« Reply #2 on: February 09, 2019, 03:27:25 pm »
I'll try to reproduce these here, but if you could upload the ufoconsole.log (and maybe some screenshots) generated the next time one of these bugs happens, it could help us track the problem down.

Offline nick87720z

  • Rookie
  • ***
  • Posts: 38
    • View Profile
Re: Some fuzzy bugs, appearing simulteneously in current 2.6
« Reply #3 on: February 10, 2019, 10:56:30 am »
Ok

I'm about to try it with new standard game, probably.

> 1) exit from hercules AirCraft (jungle map with crocodile loadscreen)
Is this true only with 4?

Usually if i wanted to cover hercules exit with smoke - the only option was to throw it to floor right before exit, otherwise it rolls down inevitably, also useful to cover soldiers after they did first cleanup. But i never throwed many grenades at one place (though one time during skirmish i tried smoke together with gas grenade - at dumb map, after passing far bridge entrance/exit.

> 2) entrance to the Hunter UfoCraft (Snow map)
What i usually get when smoke is on map, especially in several instances/places - crash with i965: Failed to submit batchbuffer I/O error, but that is way different. Never used smoke right in entrance, since it breaks ir googles which are vital in such places.
« Last Edit: February 10, 2019, 07:38:00 pm by nick87720z »

Offline nick87720z

  • Rookie
  • ***
  • Posts: 38
    • View Profile
Re: Some fuzzy bugs, appearing simulteneously in current 2.6
« Reply #4 on: February 10, 2019, 08:43:29 pm »
First bug, whose message i can't find both in bugtracker and on forum:

Window 'tipoftheday' not found
Sanity check for script data
...buildings ok
...tech ok
...aircraft ok
...items ok
...nations ok
UI_ExecuteLuaConFunc
lua error(0) [node=bases.current_employees, behaviour=confunc]: [string "bases.ufo"]:105: attempt to index a nil value
UI_ExecuteLuaConFunc
lua error(0) [node=bases.current_employees, behaviour=confunc]: [string "bases.ufo"]:105: attempt to index a nil value

(Error lines pair appeared totally 15 times)

Searching on forum i get this:
Each word must be at least two characters long.

It is only first seconds of new standard gameplay, so no visible issues yet. Possible, that it is not related to there.
For now i only created base at Africa and covered russia with 3 radars.

P.S. I wanted to add new line to terminal to separate visually next log (or some #xxxx separator), but it somehow scrambles terminal's own input feedback, making all input blind. After crash terminal is not restored, requiring to type reset to make input not blind again.
« Last Edit: February 10, 2019, 08:51:18 pm by nick87720z »

Offline nick87720z

  • Rookie
  • ***
  • Posts: 38
    • View Profile
Re: Some fuzzy bugs, appearing simulteneously in current 2.6
« Reply #5 on: February 11, 2019, 08:02:40 am »
I got first bug - failing time control buttons. It s not about keyboard. I did some base maintainance in pause when it happened. I had second base building in progress (control center, electrostation, radar, barracks) when core laser research completed, so i began aircraft laser research.

UI_ExecuteLuaEventScript
lua error(0) [node=bases.sections.facilities.content.building_lab, behaviour=panel]: [string "_assets_base.ufo"]:46: attempt to index a nil value



« Last Edit: February 11, 2019, 08:04:23 am by nick87720z »

Offline geever

  • Project Coder
  • PHALANX Commander
  • ***
  • Posts: 2534
    • View Profile
Re: Some fuzzy bugs, appearing simulteneously in current 2.6
« Reply #6 on: February 11, 2019, 08:34:33 pm »
Those Lua warnings caused no issue, it was just backend code trying to update an inactive UI. I patched them.

-geever

Offline Gu-Doc

  • Cannon Fodder
  • **
  • Posts: 5
    • View Profile
Re: Some fuzzy bugs, appearing simulteneously in current 2.6
« Reply #7 on: February 20, 2019, 08:27:44 pm »
I have an interesting discovery ,if you have two crash sides , after the first you fly the second (
without flying to base) all the grenades and ammunition you have already used  ,do not disappear  at the second  crash side . I used 2 of 2 frag grenades, but they again appeared in the second crash side . I think that  the inventory is updated only on the base , not after the battle.

P.S. All AirCrafts have containers with ammunition , so it can not be sold when it is equiped.
if such  containers  will be for soldiers ? I think there will be 3 positive effects :
1)inventory will be updated after the battle
2)you can’t sell already  equiped ammunition
3)realism

Offline geever

  • Project Coder
  • PHALANX Commander
  • ***
  • Posts: 2534
    • View Profile
Re: Some fuzzy bugs, appearing simulteneously in current 2.6
« Reply #8 on: February 21, 2019, 09:25:59 pm »
I have an interesting discovery ,if you have two crash sides , after the first you fly the second (
without flying to base) all the grenades and ammunition you have already used  ,do not disappear  at the second  crash side . I used 2 of 2 frag grenades, but they again appeared in the second crash side . I think that  the inventory is updated only on the base , not after the battle.

P.S. All AirCrafts have containers with ammunition , so it can not be sold when it is equiped.
if such  containers  will be for soldiers ? I think there will be 3 positive effects :
1)inventory will be updated after the battle
2)you can’t sell already  equiped ammunition
3)realism

Known, missing feature. The situation is a bit more complicated but the overall concept is that you wrote.

-geever