Technical support > Feature Requests

Bleeding wounds

<< < (16/20) > >>

Mattn:
patch 17 can be applied to master already, no?

maybe you want an extra branch for your work? or are you done and only finetuning is left?

DarkRain:
Yes, patch 17 is good to go, it isn't directly related to the wounds system, it was just to make my game less prone to error out of battlescape during testing and I thought it would be nice to include it.

As for the rest, the features of the wiki proposal should be implemented with only some slight modifications (that I deemed necessary), so its pretty much finished, the only part that needs some serious work is the UI part, as it stands it was just for me to have a quick visual of how things were doing during testing.

Mattn:
some style notes:

bodyPartData_t should be named BodyPartData - the getters should be const and inlined


--- Code: ---- } else if (damage < 0) {
+ } else if (damage < 0){

--- End code ---

this patch part is not needed ;)



other than that i really like it. i will try to apply this to master in the next days to get some playtesting feedback.

DarkRain:

--- Quote from: Mattn on July 16, 2012, 10:19:22 pm ---some style notes:

bodyPartData_t should be named BodyPartData - the getters should be const and inlined

--- End quote ---
Speaking of style... did you agree on the new coding guidelines already?


--- Quote ---
--- Code: ---- } else if (damage < 0) {
+ } else if (damage < 0){

--- End code ---

this patch part is not needed ;)

--- End quote ---
:o What the... that obviously wasn't meant to happen :-[

edit:
Ugh I knew I was forgetting something...
I had some AI tweaks in my working branch and patch #8 also touches g_ai.cpp, as a result it won't apply cleanly to master, use the one attached here instead, sorry about that.

Mattn:

--- Quote from: DarkRain on July 16, 2012, 10:53:04 pm ---Speaking of style... did you agree on the new coding guidelines already?

--- End quote ---

not yet - as i did not yet read everything of it. but the classnames should be upper camel case (we are using this for radiant already, too - just not for the ui (there it's lower camel case and should be fixed))

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version