project-navigation
Personal tools

Author Topic: Edit: Crazy lighting using hardware driven dynamic lighting > 1 max light  (Read 3640 times)

Offline Midaychi

  • Cannon Fodder
  • **
  • Posts: 7
    • View Profile
Edit: First post was me being a derp.
Look for my second post.


"disabled shaders because they failed to compile"
I notice this message when starting up the 2.4 dev snapshot.
I had not used any prior version within years, so I decided to see how the development had progressed since then.
Played a bit and generally the game works well, but in battlescapes I was getting some crazy lightmap glitches and actors/items were going full overbright in night missions.

For example: Tarman shoots a blaster pistol, causes the entire map to light up blue in crazy square splotches, and whacky looking reflections on every surface as it flew.

Tweaked settings a little bit and setting lightmaps to "normal" and r_modulate to 1 or .5 as well as the max hardware lights to 2 seems to make the game a lot less "HOLY BLUE" and more "Oh hey blue".
Still, I was wondering wtf was up, and I noticed the "disabled shaders because they failed to compile" message on startup, which also appears after each shader restart command issued.

So I downloaded the git version, compiled the binaries, compiled the maps and set up the archives.  Ran that version and was happy to see that some missing icons were there now, but the "disabled shaders because they failed to compile" message still pops up and I'm still getting crazy lighting issues.

Any ideas? I tried a search and a lot of other people mention it, but it never seems to be the focus on the thread. Just something in their console spam that nobody ever points out.

Windows 7/64bit, hd5750 xfx, 4 gigs of 1066 ddr2 ram, quad core phenom I black edition.

« Last Edit: October 23, 2011, 02:40:09 pm by Mattn »

Offline Mattn

  • CaveExpress
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4830
  • www.caveproductions.org
    • View Profile
    • CaveExpress
Re: "disabled shaders because they failed to compile"
« Reply #1 on: October 23, 2011, 01:38:26 pm »
reset your config.cfg in your user directory - see the faq for the path.

Offline Midaychi

  • Cannon Fodder
  • **
  • Posts: 7
    • View Profile
Re: "disabled shaders because they failed to compile"
« Reply #2 on: October 23, 2011, 02:31:31 pm »
Yeah, because I didn't start with a fresh config.cfg anyways.

Right anyways, messed with cvars a bit and managed to get the shaders compiling, was probably related to the glsl shader option randomly turning itself off for no apparent reason.

Turns out it has nothing to do with the crazy lighting.

The problem is with the hardware lighting option.

The geomap works fine, lit all great with bumpmaps, pretty etc.
Battlescapes however, some issues occur.

Here's dynamic lights set to max 1, note the lack of any non-compiled lighting, including the plasma shot.



-----

Now here's the same shot with a different plasma bolt (this time offscreen to the right), with dynlight max set to 2.



-------

Here's a similar shot with no plasma bolts on max lights set to 7



--

And finally here's a plasma shot on max lights 7.





Interesting to note that while the plasma bolt moved, the angle the 'reflections' on the edges of structures moved too.
Also, the fullbrightness of models increased with every step past 1 max light.

Offline Mattn

  • CaveExpress
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4830
  • www.caveproductions.org
    • View Profile
    • CaveExpress
please also attach your ufoconsole.log and the config.cfg that you are using right now.

Offline Midaychi

  • Cannon Fodder
  • **
  • Posts: 7
    • View Profile
Here's a ufoconsole.log of me starting the client up, changing the dynamic lights max to 1, loading up the wrong save game then the right save game, then entering a mission in russia at night. Subsequently I ended the turn so aliens would shoot and the plasma bolts gave no lighting, then set a variable in the console to set the dynamic lights max to 2 and the aliens shot and set off a plasma grenade, causing the map to turn into a blue and green tripfest instead of giving no light.

Here is the resulting config.cfg from that as well.

Offline Midaychi

  • Cannon Fodder
  • **
  • Posts: 7
    • View Profile
If I set it to 1 dynamic light, the geoscape works just fine (even mountain ranges are bumped) and the game dosen't become a tripfest on battlescape, but there's pretty much no dynamic lights.
Playable, so I'm not too worried, but its not as pretty.

Offline Midaychi

  • Cannon Fodder
  • **
  • Posts: 7
    • View Profile
cook-torrance_fs.glsl was updated recently on the git repository, so I pulled and compiled and put the archives back together to try.

Seems like the dynamic lights are starting to work more like they should; people aren't going overbright even on 7 lights and when an alien fires a plasma pistol it dosen't send the team on a lightshow trip.

There's still a little bit of a bug though; You can see it a bit in some of the previous pictures but nearby buildings do some freaky light-upping and reflecting of their own.
That's still present, but at least now the entire map doesn't turn blue and my soldiers aren't radioactively glow in the dark, and shots actually have a little light following them.

Edit: A rewording, the building overbrighting and crazy specular only happens during a dynamic light event like the plasma shot. Otherwise they're lit normally.
« Last Edit: October 28, 2011, 01:49:40 pm by Midaychi »

Offline Midaychi

  • Cannon Fodder
  • **
  • Posts: 7
    • View Profile

Offline Crystan

  • Project Artist
  • Captain
  • ***
  • Posts: 572
  • UFO:AI Lead Sound Artist
    • View Profile
    • http://crysea.cr.funpic.de/
when an alien fires a plasma pistol it dosen't send the team on a lightshow trip.

rofl and yay, finaly my new ptl effects can benfit from dynlight! :)