UFO: Alien Invasion Issue Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Bug report #482  -  Crashes on entering base after death in mission
Posted Jan 30, 2007 - updated Jan 28, 2013
icon_info.png This issue has been closed with status "Closed" and resolution "Not determined".
Issue details
  • Type of issue
    Bug report
  • Status
     
    Closed
  • Assigned to
    Not assigned to anyone
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     secret-hamster
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Category
    Engine
  • Resolution
    Not determined
  • Priority
    3. Normal
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • Complexity
    icon_customdatatype.png Not determined
  • Platform
    icon_customdatatype.png Not determined
  • Architecture
    icon_customdatatype.png Not determined
Issue description
Item 482 imported from sourceforge.net tracker on 2013-01-28 18:21:29

version info "version" is "UFO: Alien Invasion 2.1-dev3 i386 Jan 27 2007 Linux"

If you lose one of your soldiers in a mission (or at least the first, I presume it will work for any), when you try to re-enter the base by clicking on it from the geoscope then the game crashes out with an error message similar to

Error: CL_UpdateHireVar: SoldiersInBase: 4, teamNum[1]: 7, p: 4

I originally had 7 soldiers but lost 3 in the mission (boy is hard, hard them aliens just don't wanna die)

there appears to be no other errors, definately have no base/ufoconsole.log
Comments Ported from Sourceforge  ⇑ top
nobody (2007-02-02 11:18:22)  ⇑ top
Logged In: NO

related to 1650052
nobody (2007-02-02 13:47:03)  ⇑ top
Logged In: NO

please check r6017
secret-hamster (2007-02-03 07:55:02)  ⇑ top
Logged In: YES user_id=1501355 Originator: YES

just upped to build 6023 still the same issue,
voovoos (2007-02-03 23:28:14)  ⇑ top
Logged In: YES user_id=194458 Originator: NO

Can you, please, try the revision 6040? There were some other fixes after 6023 for this, and i cannot reproduce the crash with 6040 (do not use later revision, please, because of other bugs related to other code).
voovoos (2007-02-04 22:19:36)  ⇑ top
Logged In: YES user_id=194458 Originator: NO

According to originator it is fixed.
Steps to reproduce this issue
Nothing entered.