UFO: Alien Invasion Issue Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Bug report #428  -  japan06n crashes during scrolling
Posted Nov 10, 2006 - updated Jan 28, 2013
icon_info.png This issue has been closed with status "Closed" and resolution "Not determined".
Issue details
  • Type of issue
    Bug report
  • Status
     
    Closed
  • Assigned to
     cassiterite
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     kainazzzo
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Category
    Maps
  • Resolution
    Not determined
  • Priority
    3. Normal
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • Complexity
    icon_customdatatype.png Not determined
  • Platform
    icon_customdatatype.png Not determined
  • Architecture
    icon_customdatatype.png Not determined
Issue description
Item 428 imported from sourceforge.net tracker on 2013-01-28 18:21:29

When I load a mission in japan06n, and I start scrolling around, it crashes the game and says "... could not generate font surface" This happens every time, and typically in the same locations.
Comments Ported from Sourceforge  ⇑ top
kainazzzo (2006-11-10 02:45:01)  ⇑ top
Logged In: YES user_id=889556

The same thing just happened in bunker01d... I'm not sure it's the map now.
cassiterite (2006-11-10 08:00:21)  ⇑ top
Logged In: YES user_id=1171370

The "could not generate font surface" error was meant to be fixed for RC5 but it turns out it was incorrectly applied (something got messed up during code merges!).

It usually only happened when resolution was set to below 1024x768 (although this would trigger it quite easily). It is certainly possible something could have triggered it higher resolutions.

I'll leave this as open for now, but RC6 should be out in the near future so please re-test using this version and report back if the issue remains.
kainazzzo (2006-11-11 20:06:57)  ⇑ top
Logged In: YES user_id=889556

cassiterite,

That is exactly what happened. I had just switched my resolution down to 800x600 so I could run it in a window. I put it back to fullscreen, and it works great now smileys/2.png

Looking forward to RC6!!
tlh2000 (2006-11-12 17:33:05)  ⇑ top
Logged In: YES user_id=116930

should be fixed for rc6
Steps to reproduce this issue
Nothing entered.