UFO: Alien Invasion Issue Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Bug report #415  -  error at start-up
Posted Oct 14, 2006 - updated Jan 28, 2013
icon_info.png This issue has been closed with status "Closed" and resolution "Not determined".
Issue details
  • Type of issue
    Bug report
  • Status
     
    Closed
  • Assigned to
    Not assigned to anyone
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     garrett01001
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Category
    General
  • Resolution
    Not determined
  • Priority
    3. Normal
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • Complexity
    icon_customdatatype.png Not determined
  • Platform
    icon_customdatatype.png Not determined
  • Architecture
    icon_customdatatype.png Not determined
Issue description
Item 415 imported from sourceforge.net tracker on 2013-01-28 18:21:29

"GLimp_EndFrame() - SwapBuffers() failed!"

I have no idea what to do.. I'm running Windows XP Pro SP2 768MB RAM 2GB Virtual Mem 2GB Page File AMD 1.6ghz

I get the same error every time..
Comments Ported from Sourceforge  ⇑ top
nobody (2006-10-15 18:29:40)  ⇑ top
Logged In: NO

This might be a long-shot but have you ruled out the possibility that the download was somehow corrupted? The md5sums are posted at http://ufoai.net/ . There is an md5sum checker for windows at http://www.md5summer.org/download.html

Can you also specify the video card drivers you have installed?

 
nobody (2006-10-16 07:10:18)  ⇑ top
Logged In: NO

try to change the gl_drawbuffer cvar to GL_FRONT or something other than GL_BACK

to do this make a link to ufo.exe and add the following to the commandline:

    +set gl_drawbuffer GL_FRONT


please report back - which graphics card and which drivers? you should also append the ufoconsole.log from base/ dir to this tracker.
garrett01001 (2006-10-18 22:55:23)  ⇑ top
Logged In: YES user_id=1287582

I did what you suggested, I added '+set gl_draw....' to the command line.. Now it starts up and shows me some menus, but it freezes.. I am attaching the console.log file.

This computer is what i like to call a 'craptop', premade laptop that costs less than $500..

graphics card is S3G or something..

chip type: UniChrome Pro IGP video memory: 64mb display drive: vtdisp.dll 6.14.10.0209-16.94.42.13 opengl icd: vticd.dll 6.14.10.0209-16.94.42.13 directc: 9.0c directx media: 6.05.2600.2180
cassiterite (2006-10-19 15:15:27)  ⇑ top
Logged In: YES user_id=1171370

From your log file:

"...max texture size:

......cannot detect !"

Looks like the program is having trouble polling your graphics card for some essential details.

How do other games run on the laptop? If you have time can you try running Nexuiz on that computer (http://www.alientrap.org/nexuiz/). I plan to sit down and compare the way nexuiz sets up the graphics vs our code (the code-bases share many similarities which should make the process easier).
tlh2000 (2007-09-25 16:27:56)  ⇑ top
Logged In: YES user_id=116930 Originator: NO

this should be fixed due to the usage of the sdl renderer for every plattform
Steps to reproduce this issue
Nothing entered.