UFO: Alien Invasion Issue Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Bug report #393  -  when fullscreen is set you can scroll out of the real window
Posted Oct 03, 2006 - updated Jan 28, 2013
icon_info.png This issue has been closed with status "Closed" and resolution "Not determined".
Issue details
  • Type of issue
    Bug report
  • Status
     
    Closed
  • Assigned to
     mattn
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     xtermique
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Category
    User interface
  • Resolution
    Not determined
  • Priority
    3. Normal
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • Complexity
    icon_customdatatype.png Not determined
  • Platform
    icon_customdatatype.png Not determined
  • Architecture
    icon_customdatatype.png Not determined
Issue description
Item 393 imported from sourceforge.net tracker on 2013-01-28 18:18:28

Using 2.0RC5 in my RH fedora core 1 it can be reproduced when starting the game and trying to move a mouse out of an edge of the screen (then youl will see some of your desktop on the game screen).
                                                      
                         
It also occurs when playing a game (and is very annoying), although I'm not able give an exact recipe how to reproduce it.
Comments Ported from Sourceforge  ⇑ top
nobody (2006-10-04 10:45:12)  ⇑ top
Logged In: NO

only if the game resolution is another one as you use on the desktop?

did you try both renderers? ./ufo +set vid_ref sdl ./ufo +set vid_ref glx

you can even try the +set vid_grabmouse 1 parameter
xtermique (2006-10-04 17:10:14)  ⇑ top
Logged In: YES user_id=1612448

OK, the problem seems to come out when game resolution < screen resolution AND when ./ufo +set vid_ref glx (or without passing any paramethers in my case).

Using ./ufo +set vid_ref sdl doesn&#039;t show problematic behavior (at least when starting the game as reported in the first post)

What is the vid_grabmouse for?
 
cassiterite (2006-10-25 09:29:12)  ⇑ top
Logged In: YES user_id=1171370

you can also work-around this issue by running the game in windowed mode (+set vid_fullscreen 0 +set vid_grabmouse 0). The vid_grabmouse option is supposedly meant to set whether the game grabs your mouse completely or not. As "nobody" suggested, setting this to 1 might potentially fix the issue in fullscreen mode with the glx renderer.

Recently I applied a patch to trunk which changes the cursor behavior slightly in glx mode. It has a slim chance of fixing this issue (I need to test myself since I&#039;ve had these scroll issues myself.. but lately I&#039;ve been running in windowed mode since it is more stable).

PS: if you get it again, I found rapidly moving my mouse to the top-left of the screen multiple times usually shifted things back...
Steps to reproduce this issue
Nothing entered.