UFO: Alien Invasion Issue Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Bug report #329  -  Crash at after base defence mission summary
Posted Sep 11, 2006 - updated Jan 28, 2013
icon_info.png This issue has been closed with status "Closed" and resolution "Not determined".
Issue details
  • Type of issue
    Bug report
  • Status
     
    Closed
  • Assigned to
    Not assigned to anyone
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     jonnyba
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Category
    General
  • Resolution
    Not determined
  • Priority
    3. Normal
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • Complexity
    icon_customdatatype.png Not determined
  • Platform
    icon_customdatatype.png Not determined
  • Architecture
    icon_customdatatype.png Not determined
Issue description
Item 329 imported from sourceforge.net tracker on 2013-01-28 18:18:28

Played the first base defence and finished the mission. Mission summary screen is ok but then the game crashes (see screenshot attached).

System: Windows XP Version: UFOAI-SVN-3490
Comments Ported from Sourceforge  ⇑ top
jonnyba (2006-09-11 22:30:47)  ⇑ top
Screenshot of Error Message Window
bandobraz (2006-09-12 00:05:21)  ⇑ top
Logged In: YES user_id=1557623

This seems to be the same bug as 1554953 Crash at too many employees. Does it also happen after other missions?
jonnyba (2006-09-12 13:10:58)  ⇑ top
Logged In: YES user_id=1595834

Ok i did this:

I installed SVN-3530, loaded the savegame i made before entering the base mission and it crashes immediately during the process of loading (error message "moz-error2.jpg" attached).

Other savegames load fine. It was my first base defence mission at all and i hired just 28 employees (9 soldiers, 19 scientists), never happened before at all.
jonnyba (2006-09-12 13:53:28)  ⇑ top
Logged In: YES user_id=1595834

Next crash: I played the last savegame i made before the base defence mission was avaible, started a (normal terror) mission and in the end it crashed as well (error message attached "moz-error3.jpg").

I remember now i hired other 7 scientists not long ago, before i had just 12 of them. Next try will be to fire science guys ...
rani_shrim (2006-09-15 07:16:52)  ⇑ top
Logged In: YES user_id=667501

Should be realted to employee bug. Can we see a log with "set developer 1" plz?
cassiterite (2006-10-25 09:49:18)  ⇑ top
Logged In: YES user_id=1171370

I'm quite sure this is related to the employee overflow bug which is fixed fixed in trunk, RC5 and 2.0 stable branch. Until recently stable branch also suffered the save-game bug which made it hard to get to a base defense mission. Over the next few days 2.0 branch will be updated further, but even in its current state please test it to see if you can reproduce this issue (or test trunk SVN).

Marking this bug as pending (pending feedback from jonnyba or others about the reproduceability of this bug in recent SVN versions).
sf-robot (2006-11-09 03:20:04)  ⇑ top
Logged In: YES user_id=1312539

This Tracker item was closed automatically by the system. It was previously set to a Pending status, and the original submitter did not respond within 14 days (the time period specified by the administrator of this Tracker).
Steps to reproduce this issue
Nothing entered.