UFO: Alien Invasion Issue Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Bug report #292  -  Segfault when changing resolution.
Posted Sep 03, 2006 - updated Jan 28, 2013
icon_info.png This issue has been closed with status "Closed" and resolution "Not determined".
Issue details
  • Type of issue
    Bug report
  • Status
     
    Closed
  • Assigned to
    Not assigned to anyone
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     dimstar
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Category
    General
  • Resolution
    Not determined
  • Priority
    3. Normal
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • Complexity
    icon_customdatatype.png Not determined
  • Platform
    icon_customdatatype.png Not determined
  • Architecture
    icon_customdatatype.png Not determined
Issue description
Item 292 imported from sourceforge.net tracker on 2013-01-28 18:15:21

The procedure can be reproduced (at least on my computer, don't have access to another smileys/2.png )

I do: ./ufo (game starts FULLSCREEN) go to 'options' change the resolution from 1024x768 to 1280x1024 click on EXIT (or any other link, like AUDIO etc.) the game Segfaults immediate.

Backtrace attached. If you need more information (maybe more debuginfo of libraries?) let me know. I can try to get them.

Regards, Dominique
Comments Ported from Sourceforge  ⇑ top
dimstar (2006-09-03 18:05:42)  ⇑ top
bt full of segfault when changing resolution
nobody (2006-09-04 08:37:33)  ⇑ top
Logged In: NO

please try again with current rev.
dimstar (2006-09-04 16:39:18)  ⇑ top
Logged In: YES user_id=263934

updated from SVN to revision 3313

recompiled (make clean; make -j 3) started ufo went to options, changed resolution, clicked exit,

Program still segfaults.
nobody (2006-09-06 18:15:24)  ⇑ top
Logged In: NO

tried to update to 3313 Trunk; the problem persists.
dimstar (2006-09-13 13:54:39)  ⇑ top
Logged In: YES user_id=263934

Tried with the latest drivers from nVidia (1884) (as we assumed a Graphic Driver Problem) and the problem is still there.

I also tested Nezius (as discussed in chat) and to change the resolution there; Nezius does NOT HAVE this issue.
 
dimstar (2006-09-18 12:25:06)  ⇑ top
Logged In: YES user_id=263934

The developmet seems to go in the wrong direction: -At the beginning (when I opened this bugreport), only changin resolution in full screen mode was affected. In the latest SVN Release, resolution change is not possible in fullscreen AND in windowed mode.

Also, changing from Windows to Fullscreen is not possible anymore (except with start parameters)

Tell me if you need more information.
tlh2000 (2007-02-19 10:09:08)  ⇑ top
Logged In: YES user_id=116930 Originator: NO

is this bug still 'alive'? - should at least be fixed in trunk afaik
dimstar (2007-02-19 10:50:05)  ⇑ top
Logged In: YES user_id=263934 Originator: YES

Last time I checked it was still an issue.. can't tell what version it was.

So I'll just check out the latest SVN these days and give a status report of it. So we know for sure.
tlh2000 (2007-04-02 10:15:07)  ⇑ top
Logged In: YES user_id=116930 Originator: NO

if this is still in 2.1 - please reopen
sf-robot (2007-04-17 02:20:05)  ⇑ top
Logged In: YES user_id=1312539 Originator: NO

This Tracker item was closed automatically by the system. It was previously set to a Pending status, and the original submitter did not respond within 14 days (the time period specified by the administrator of this Tracker).
Steps to reproduce this issue
Nothing entered.