UFO: Alien Invasion Issue Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Bug report #2128  -  exiting Battlescape on first shot fired
Posted Jun 20, 2009 - updated Dec 21, 2013
icon_info.png This issue has been closed with status "Closed" and resolution "Not determined".
Issue details
  • Type of issue
    Bug report
  • Status
     
    Closed
  • Assigned to
    Not assigned to anyone
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     vsz
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Category
    Battlescape
  • Resolution
    Not determined
  • Priority
    3. Normal
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • Complexity
    icon_customdatatype.png Not determined
  • Platform
    icon_customdatatype.png Not determined
  • Architecture
    icon_customdatatype.png Not determined
Issue description
Item 2128 imported from sourceforge.net tracker on 2013-01-28 19:22:20

2.3-dev-win32-24761

In battlescape, the first time one of my soldiers fire, the game leaves battlescape, going back to the time frame exactly before entering the battle (So I can enter the battle an unlimited number of times, and each time being kicked out first time I fire, even when not aimed at a target) If I click autoresolve, I always win without losses. (At least the first 5, 6 or so battles)

Console output:

ERROR: LE_NotFoundError: Could not get LE with entnum 0 (C:\SVN Update\src\client\events\actor\e_event_actorshoot.c:127)
Shutdown server: Server crashed

ShutdownGame  ⇑ top

Comments Ported from Sourceforge  ⇑ top
tlh2000 (2009-06-22 04:55:36)  ⇑ top
should already be fixed in most recent trunk
tlh2000 (2009-06-22 04:56:09)  ⇑ top
see https://sourceforge.net/tracker/?func=detail&aid=2809485&group_id=157793&atid=805242
sf-robot (2009-07-07 02:20:13)  ⇑ top
This Tracker item was closed automatically by the system. It was previously set to a Pending status, and the original submitter did not respond within 14 days (the time period specified by the administrator of this Tracker).
Steps to reproduce this issue
Nothing entered.