UFO: Alien Invasion Issue Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Bug report #2  -  Grenade Bug (Linux only??)
Posted Jan 21, 2006 - updated Jan 28, 2013
icon_info.png This issue has been closed with status "Closed" and resolution "Not determined".
Issue details
  • Type of issue
    Bug report
  • Status
     
    Closed
  • Assigned to
    Not assigned to anyone
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     mattn
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Category
    General
  • Resolution
    Not determined
  • Priority
    3. Normal
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • Complexity
    icon_customdatatype.png Not determined
  • Platform
    icon_customdatatype.png Not determined
  • Architecture
    icon_customdatatype.png Not determined
Issue description
Item 2 imported from sourceforge.net tracker on 2013-01-28 18:08:35

Granades: No throwline and no explosion - but sound grenade falls through the ceiling cl_actor.c: void CL_TargetingGrenade( pos3_t fromPos, pos3_t toPos )
Comments Ported from Sourceforge  ⇑ top
robrendell (2006-02-07 04:57:07)  ⇑ top
Logged In: YES user_id=1433173

I believe I've fixed this. The y position was being reduced by 30, when the nominal height of the starting position was only about 10 above the plane of the floor.

The reason changing the targetting offset to the y value messed up the animation was because there was a reproduction of the same calculation on the server, and there was confusion when the targetting and the server's calculations didn't agree.

Could you update and confirm that it's working better for you?
 
tlh2000 (2006-02-07 08:04:31)  ⇑ top
Logged In: YES user_id=116930

Fixed in: cl_actor r.1.13 cl_campaign r.1.4 g_client.c r.1.6

Works good under Linux now. Thanks Rob
Steps to reproduce this issue
Nothing entered.