UFO: Alien Invasion Issue Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Bug report #191  -  FIXME is wrong :)
Posted Jul 30, 2006 - updated Jan 28, 2013
icon_info.png This issue has been closed with status "Closed" and resolution "Not determined".
Issue details
  • Type of issue
    Bug report
  • Status
     
    Closed
  • Assigned to
     mattn
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     bandobraz
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Category
    Engine
  • Resolution
    Not determined
  • Priority
    1. Very low
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • Complexity
    icon_customdatatype.png Not determined
  • Platform
    icon_customdatatype.png Not determined
  • Architecture
    icon_customdatatype.png Not determined
Issue description
Item 191 imported from sourceforge.net tracker on 2013-01-28 18:11:52

This FIXME is wrong:

/* FIXME; aircraft->idx is (or can be) -1 here */ /* select mission - send aircraft - on the flight - select aircraft on geoscape */ /* let aircraft arrive at mission - popup appear - mission won't start up */ /* because gd.interceptAircraft is -1 */ gd.interceptAircraft = aircraft->idx; MAP_SelectMission(aircraft->mission); Com_DPrintf("gd.interceptAircraft: %i\n", gd.interceptAircraft);

because gd.interceptAircraft is set to -1 in MAP_ResetAction in MAP_SelectMission in client/cl_map.c
Comments Ported from Sourceforge  ⇑ top
tlh2000 (2006-07-30 07:43:47)  ⇑ top
Logged In: YES user_id=116930

nevertheless there was an error - gd.interceptAircraft = aircraft->idx;is now behind MAP_SelectMission
Steps to reproduce this issue
Nothing entered.